summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:48:13 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:48:13 +0000
commit46340f07b03a2b1f79931e87ce3424026f78b046 (patch)
tree0ccc342f0398e8dedc5a31c717083ce023b6413c /x11-misc/tinynotify-send
parentImport the live ebuild. (diff)
downloadgentoo-2-46340f07b03a2b1f79931e87ce3424026f78b046.tar.gz
gentoo-2-46340f07b03a2b1f79931e87ce3424026f78b046.tar.bz2
gentoo-2-46340f07b03a2b1f79931e87ce3424026f78b046.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'x11-misc/tinynotify-send')
-rw-r--r--x11-misc/tinynotify-send/ChangeLog7
-rw-r--r--x11-misc/tinynotify-send/tinynotify-send-9999.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/x11-misc/tinynotify-send/ChangeLog b/x11-misc/tinynotify-send/ChangeLog
index be18224e43c1..63bb4e47b5da 100644
--- a/x11-misc/tinynotify-send/ChangeLog
+++ b/x11-misc/tinynotify-send/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/tinynotify-send
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinynotify-send/ChangeLog,v 1.8 2012/08/31 08:25:22 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinynotify-send/ChangeLog,v 1.9 2012/12/15 12:48:13 mgorny Exp $
+
+*tinynotify-send-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +tinynotify-send-9999.ebuild:
+ Import the live ebuild.
31 Aug 2012; Michał Górny <mgorny@gentoo.org> metadata.xml,
tinynotify-send-1.2.1.ebuild:
diff --git a/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild b/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild
new file mode 100644
index 000000000000..db2905ce8f36
--- /dev/null
+++ b/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinynotify-send/tinynotify-send-9999.ebuild,v 1.1 2012/12/15 12:48:13 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="A notification sending utility (using libtinynotify)"
+HOMEPAGE="https://bitbucket.org/mgorny/tinynotify-send/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink"
+
+RDEPEND="x11-libs/libtinynotify
+ ~x11-libs/libtinynotify-cli-${PV}
+ symlink? ( !x11-libs/libnotify[symlink] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+DEPEND="${DEPEND}
+ dev-util/gtk-doc"
+#endif
+
+src_configure() {
+ myeconfargs=(
+ --disable-library
+ --enable-regular
+ --disable-system-wide
+ --with-system-wide-exec=/usr/bin/sw-notify-send
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ use symlink && dosym tinynotify-send /usr/bin/notify-send
+}