summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2005-07-15 12:43:33 +0000
committerTom Martin <slarti@gentoo.org>2005-07-15 12:43:33 +0000
commit043a9fca0384187757cf1fafa9cea513024baca5 (patch)
tree4a15256386cb7b3dc6c3bffdabdfc1c0478e93a0 /x11-misc/viewglob
parentRemove old ebuilds. (diff)
downloadgentoo-2-043a9fca0384187757cf1fafa9cea513024baca5.tar.gz
gentoo-2-043a9fca0384187757cf1fafa9cea513024baca5.tar.bz2
gentoo-2-043a9fca0384187757cf1fafa9cea513024baca5.zip
Initial import, #63484
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc/viewglob')
-rw-r--r--x11-misc/viewglob/ChangeLog11
-rw-r--r--x11-misc/viewglob/Manifest4
-rw-r--r--x11-misc/viewglob/metadata.xml17
-rw-r--r--x11-misc/viewglob/viewglob-2.0.2.ebuild56
4 files changed, 88 insertions, 0 deletions
diff --git a/x11-misc/viewglob/ChangeLog b/x11-misc/viewglob/ChangeLog
new file mode 100644
index 000000000000..08097e4235ad
--- /dev/null
+++ b/x11-misc/viewglob/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-misc/viewglob
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/viewglob/ChangeLog,v 1.1 2005/07/15 12:43:33 slarti Exp $
+
+*viewglob-2.0.2 (15 Jul 2005)
+
+ 15 Jul 2005; Tom Martin <slarti@gentoo.org> +metadata.xml,
+ +viewglob-2.0.2.ebuild:
+ Initial import, resolves bug 63484. Thanks to Stephen Bach
+ <sjbach@users.sourceforge.net> for the submission.
+
diff --git a/x11-misc/viewglob/Manifest b/x11-misc/viewglob/Manifest
new file mode 100644
index 000000000000..4fddd3e83dd3
--- /dev/null
+++ b/x11-misc/viewglob/Manifest
@@ -0,0 +1,4 @@
+MD5 b3e5d012bfb70aca7fa16777d015575b viewglob-2.0.2.ebuild 840
+MD5 28aa757144c6d140d7ea532c2365232a metadata.xml 542
+MD5 8412a3da2bccdc3f0ad6df6be8732373 files/viewglob-2.0.2-64bit.patch 637
+MD5 191806273afbdb50baf9eb35843d8796 files/digest-viewglob-2.0.2 66
diff --git a/x11-misc/viewglob/metadata.xml b/x11-misc/viewglob/metadata.xml
new file mode 100644
index 000000000000..e6222c252f07
--- /dev/null
+++ b/x11-misc/viewglob/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>slarti@gentoo.org</email>
+ <name>Tom Martin</name>
+ </maintainer>
+ <longdescription lang="en">
+ Viewglob is a package that graphically displays the results of a shell
+ glob, helping beginners of shell usage become acclimitised to filename
+ generation. In addition, it acts as a basic replacement for ls, by
+ tracking shell directory changes. It is compatible with zsh and bash,
+ and helper files and documentation are provided.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/x11-misc/viewglob/viewglob-2.0.2.ebuild b/x11-misc/viewglob/viewglob-2.0.2.ebuild
new file mode 100644
index 000000000000..ebc652d63c81
--- /dev/null
+++ b/x11-misc/viewglob/viewglob-2.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/viewglob/viewglob-2.0.2.ebuild,v 1.1 2005/07/15 12:43:33 slarti Exp $
+
+inherit eutils
+
+DESCRIPTION="Graphical display of directories and globs referenced at the shell prompt"
+HOMEPAGE="http://viewglob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewglob/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.2.0
+ >=x11-libs/gtk+-2.4.0
+ || ( app-shells/bash app-shells/zsh )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/viewglob-2.0.2-64bit.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc AUTHORS COPYING COPYING2 ChangeLog HACKING INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo " "
+ einfo "/usr/bin/viewglob is a wrapper for vgd and vgseer (client and"
+ einfo "daemon, respectively). Generally speaking, this is what you want to"
+ einfo "execute from your shell."
+ einfo " "
+ einfo "Should you prefer to start viewglob with each shell session, try"
+ einfo "something like this:"
+ einfo " "
+ einfo ' if [[ ! $VG_VIEWGLOB_ACTIVE && $DISPLAY ]] ; then'
+ einfo ' exec viewglob'
+ einfo ' fi'
+ einfo " "
+ einfo "Have a look at http://viewglob.sourceforge.net/faq.html for a"
+ einfo "couple more viewglob tricks."
+ ewarn " "
+ ewarn "There are some known bugs in viewglob with screen. Exercise some"
+ ewarn "caution and take results with a pinch of salt if you try the two"
+ ewarn "together."
+ ewarn " "
+}