summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Martin <slarti@gentoo.org>2005-08-02 09:15:32 +0000
committerTom Martin <slarti@gentoo.org>2005-08-02 09:15:32 +0000
commit42393fb338b36361ad075e2c9e31303a7cba350b (patch)
tree49449c05a30ed1d5c82719c4ecbbd572f2a9e81f /x11-misc/viewglob
parentStable on x86. (diff)
downloadgentoo-2-42393fb338b36361ad075e2c9e31303a7cba350b.tar.gz
gentoo-2-42393fb338b36361ad075e2c9e31303a7cba350b.tar.bz2
gentoo-2-42393fb338b36361ad075e2c9e31303a7cba350b.zip
Version bump to 2.0.3; resolves bug 99796.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc/viewglob')
-rw-r--r--x11-misc/viewglob/ChangeLog7
-rw-r--r--x11-misc/viewglob/files/digest-viewglob-2.0.31
-rw-r--r--x11-misc/viewglob/viewglob-2.0.3.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-misc/viewglob/ChangeLog b/x11-misc/viewglob/ChangeLog
index 0d04fb269e20..a8bddb739193 100644
--- a/x11-misc/viewglob/ChangeLog
+++ b/x11-misc/viewglob/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/viewglob
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/viewglob/ChangeLog,v 1.4 2005/07/16 11:40:28 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/viewglob/ChangeLog,v 1.5 2005/08/02 09:15:32 slarti Exp $
+
+*viewglob-2.0.3 (02 Aug 2005)
+
+ 02 Aug 2005; Tom Martin <slarti@gentoo.org> +viewglob-2.0.3.ebuild:
+ Version bump, resolves bug 99796.
16 Jul 2005; David Holm <dholm@gentoo.org> viewglob-2.0.2.ebuild:
Added to ~ppc.
diff --git a/x11-misc/viewglob/files/digest-viewglob-2.0.3 b/x11-misc/viewglob/files/digest-viewglob-2.0.3
new file mode 100644
index 000000000000..e5ab762291bd
--- /dev/null
+++ b/x11-misc/viewglob/files/digest-viewglob-2.0.3
@@ -0,0 +1 @@
+MD5 2c0b9713c4171edebae3f553e0b8efbb viewglob-2.0.3.tar.gz 325355
diff --git a/x11-misc/viewglob/viewglob-2.0.3.ebuild b/x11-misc/viewglob/viewglob-2.0.3.ebuild
new file mode 100644
index 000000000000..29794676fe38
--- /dev/null
+++ b/x11-misc/viewglob/viewglob-2.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/viewglob/viewglob-2.0.3.ebuild,v 1.1 2005/08/02 09:15:32 slarti Exp $
+
+inherit eutils
+
+DESCRIPTION="Graphical display of directories and globs referenced at the shell prompt"
+HOMEPAGE="http://viewglob.sourceforge.net/"
+SRC_URI="mirror://sourceforge/viewglob/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.2.0
+ >=x11-libs/gtk+-2.4.0
+ || ( app-shells/bash app-shells/zsh )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc AUTHORS COPYING COPYING2 ChangeLog HACKING INSTALL NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo " "
+ einfo "/usr/bin/viewglob is a wrapper for vgd and vgseer (client and"
+ einfo "daemon, respectively). Generally speaking, this is what you want to"
+ einfo "execute from your shell."
+ einfo " "
+ einfo "Should you prefer to start viewglob with each shell session, try"
+ einfo "something like this:"
+ einfo " "
+ einfo ' if [[ ! $VG_VIEWGLOB_ACTIVE && $DISPLAY ]] ; then'
+ einfo ' exec viewglob'
+ einfo ' fi'
+ einfo " "
+ einfo "Have a look at http://viewglob.sourceforge.net/faq.html for a"
+ einfo "few more viewglob tricks."
+ ewarn " "
+ ewarn "There are some known bugs in viewglob with screen. Exercise some"
+ ewarn "caution and take results with a pinch of salt if you try the two"
+ ewarn "together."
+ ewarn " "
+}