summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-09 16:44:42 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-09 16:44:42 +0000
commit5f63ba1bd0a16622ef45638901d55e74afd222f5 (patch)
tree64db937a5950f565ff14ce3d5619a17843e446dc /x11-misc/xautolock/xautolock-2.2.ebuild
parentRemove unnecessary KDE_MINIMAL, properly change SLOT (diff)
downloadgentoo-2-5f63ba1bd0a16622ef45638901d55e74afd222f5.tar.gz
gentoo-2-5f63ba1bd0a16622ef45638901d55e74afd222f5.tar.bz2
gentoo-2-5f63ba1bd0a16622ef45638901d55e74afd222f5.zip
Respect CC, CCFLAGS and LDFLAGS. Fixes bug 331789. Thanks Diego for the report
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xautolock/xautolock-2.2.ebuild')
-rw-r--r--x11-misc/xautolock/xautolock-2.2.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-misc/xautolock/xautolock-2.2.ebuild b/x11-misc/xautolock/xautolock-2.2.ebuild
index 571ebcd5095c..3524b0ad9c51 100644
--- a/x11-misc/xautolock/xautolock-2.2.ebuild
+++ b/x11-misc/xautolock/xautolock-2.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xautolock/xautolock-2.2.ebuild,v 1.1 2008/03/23 15:11:21 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xautolock/xautolock-2.2.ebuild,v 1.2 2010/08/09 16:44:42 xarthisius Exp $
+
+inherit toolchain-funcs
DESCRIPTION="An automatic X screen-locker/screen-saver."
SRC_URI="http://www.ibiblio.org/pub/Linux/X11/screensavers/${P}.tgz"
@@ -20,12 +22,12 @@ DEPEND="${RDEPEND}
src_compile() {
xmkmf || die
- emake || die
+ emake EXTRA_LDOPTIONS="${LDFLAGS}" CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" || die
}
src_install () {
- into /usr
dobin xautolock || die
newman xautolock.man xautolock.1
- dodoc Changelog Readme Todo
+ dodoc Changelog Readme Todo || die
}