summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2010-10-29 21:52:42 +0000
committerChristian Birchinger <joker@gentoo.org>2010-10-29 21:52:42 +0000
commit7f0dde0abd93063d631dbe68753de9f540d91a6d (patch)
tree1dfaa5f8f59212b5b10d8cb9939340f29e974e18 /x11-misc/xdotool/xdotool-2.20100818.3004.ebuild
parentVersion bump for Gnome 2.32, let it compile when python3 is set as main inter... (diff)
downloadgentoo-2-7f0dde0abd93063d631dbe68753de9f540d91a6d.tar.gz
gentoo-2-7f0dde0abd93063d631dbe68753de9f540d91a6d.tar.bz2
gentoo-2-7f0dde0abd93063d631dbe68753de9f540d91a6d.zip
Prevent ldconfig execution by the Makefile
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xdotool/xdotool-2.20100818.3004.ebuild')
-rw-r--r--x11-misc/xdotool/xdotool-2.20100818.3004.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild b/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild
index 1d2a518c6d93..9df4226befd5 100644
--- a/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild
+++ b/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild,v 1.2 2010/09/22 17:25:54 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-2.20100818.3004.ebuild,v 1.3 2010/10/29 21:52:42 joker Exp $
EAPI=2
@@ -26,6 +26,11 @@ RDEPEND="${DEPEND}"
# and add a full blown gnome just to run the tests.
RESTRICT="test"
+src_prepare() {
+ sed -e "s/installheader post-install$/installheader/" \
+ -i Makefile || die "sed failed"
+}
+
src_compile() {
tc-export CC LD
default