summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-07 16:23:45 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-07 16:23:45 +0000
commitad5b8c7b6ec1633e8601de95acd6f2a4738e1078 (patch)
tree7a75fba17295d6a6e6dab3438396a3d5a8bb397f /x11-misc/xkeyboard-config
parentVersion bump. Remove old. (diff)
downloadgentoo-2-ad5b8c7b6ec1633e8601de95acd6f2a4738e1078.tar.gz
gentoo-2-ad5b8c7b6ec1633e8601de95acd6f2a4738e1078.tar.bz2
gentoo-2-ad5b8c7b6ec1633e8601de95acd6f2a4738e1078.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog10
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index c12d99bb5b17..8075596b64d6 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xkeyboard-config
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.204 2014/11/04 16:56:31 chithanh Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.205 2015/02/07 16:23:45 chithanh Exp $
+
+*xkeyboard-config-2.14 (07 Feb 2015)
+
+ 07 Feb 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xkeyboard-config-2.14.ebuild:
+ Version bump.
*xkeyboard-config-2.13 (04 Nov 2014)
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild
new file mode 100644
index 000000000000..1209f4f89e2f
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-2.14.ebuild,v 1.1 2015/02/07 16:23:45 chithanh Exp $
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=x11-apps/xkbcomp-1.2.3
+ >=x11-libs/libX11-1.4.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=x11-proto/xproto-7.0.20"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}
+
+src_compile() {
+ # cleanup to make sure .dir files are regenerated
+ # bug #328455 c#26
+ xorg-2_src_compile clean
+ xorg-2_src_compile
+}