summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-15 22:54:27 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-15 22:54:27 +0000
commit53bb000864eddae0e1a33f295ff0ea6bfe2545b7 (patch)
treedb9b17cd8a43c1f20c173f727ea2ccf3cc8ad8e5 /x11-misc/xmbdfed
parentVersion bump, fixing bug #245320. (diff)
downloadgentoo-2-53bb000864eddae0e1a33f295ff0ea6bfe2545b7.tar.gz
gentoo-2-53bb000864eddae0e1a33f295ff0ea6bfe2545b7.tar.bz2
gentoo-2-53bb000864eddae0e1a33f295ff0ea6bfe2545b7.zip
Truetype support is not optional any more in this package thus removed truetype USE flag, fixes bug #248584, thank Diego E. 'Flameeyes' Pettenò for report. Respect CC and LDFLAGS.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'x11-misc/xmbdfed')
-rw-r--r--x11-misc/xmbdfed/ChangeLog7
-rw-r--r--x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild27
2 files changed, 20 insertions, 14 deletions
diff --git a/x11-misc/xmbdfed/ChangeLog b/x11-misc/xmbdfed/ChangeLog
index 670a839001ab..5282404ded1e 100644
--- a/x11-misc/xmbdfed/ChangeLog
+++ b/x11-misc/xmbdfed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xmbdfed
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmbdfed/ChangeLog,v 1.18 2008/03/16 22:00:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmbdfed/ChangeLog,v 1.19 2008/12/15 22:54:27 pva Exp $
+
+ 15 Dec 2008; Peter Volkov <pva@gentoo.org> xmbdfed-4.7_p1.ebuild:
+ Truetype support is not optional any more in this package thus removed
+ truetype USE flag, fixes bug #248584, thank Diego E. 'Flameeyes' Pettenò
+ for report. Respect CC and LDFLAGS.
16 Mar 2008; Ulrich Mueller <ulm@gentoo.org> xmbdfed-4.7_p1.ebuild:
Remove calls to motif-config, fixes bug 211844.
diff --git a/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild b/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild
index 3849a4797558..e34fbe8db38b 100644
--- a/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild
+++ b/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild,v 1.8 2008/03/16 22:00:58 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmbdfed/xmbdfed-4.7_p1.ebuild,v 1.9 2008/12/15 22:54:27 pva Exp $
-inherit eutils
+inherit eutils toolchain-funcs
MY_P=${P/_p*}
DESCRIPTION="BDF font editor for X"
@@ -13,10 +13,10 @@ HOMEPAGE="http://clr.nmsu.edu/~mleisher/xmbdfed.html"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 ppc"
-IUSE="truetype"
+IUSE=""
DEPEND=">=x11-libs/openmotif-2.3.0-r1
- truetype? ( media-libs/freetype )"
+ media-libs/freetype"
S=${WORKDIR}/${MY_P}
@@ -25,29 +25,30 @@ src_unpack() {
cd "${S}"
epatch "${DISTDIR}/${P/_p/-patch}"
epatch "${FILESDIR}/${P}-gcc4.patch"
+ sed -e 's:\(-o xmbdfed \): $(LDFLAGS) \1:' -i Makefile || die
}
src_compile() {
# There's no ./configure in xmbdfed, so perform the make by manually
# specifying the correct options for Gentoo.
-
local flags=""
local incs=""
local libs="-lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE"
- if use truetype ; then
- flags="FTYPE_DEFS=\"-DHAVE_FREETYPE\""
- incs="${incs} `freetype-config --cflags`"
- libs="${libs} `freetype-config --libs`"
- fi
+ flags="FTYPE_DEFS=\"-DHAVE_FREETYPE\""
+ incs="${incs} `freetype-config --cflags`"
+ libs="${libs} `freetype-config --libs`"
- make CFLAGS="${CFLAGS}" ${flags} \
+ make CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ ${flags} \
+ LDFLAGS="${LDFLAGS}" \
INCS="${incs}" \
LIBS="${libs}" || die
}
src_install() {
- dobin xmbdfed
+ dobin xmbdfed || die
newman xmbdfed.man xmbdfed.1
- dodoc CHANGES COPYRIGHTS INSTALL README xmbdfedrc
+ dodoc CHANGES README xmbdfedrc
}