summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-11-15 22:04:31 +0000
committerJeroen Roovers <jer@gentoo.org>2011-11-15 22:04:31 +0000
commitc42c3268acee611bc3f2d3c49aae38b26801780d (patch)
treeee7b0da840ab542c41d0790e3ece4df15cedde8a /x11-misc/xsnap
parentVersion bump. Add gnome to herd list. (diff)
downloadgentoo-2-c42c3268acee611bc3f2d3c49aae38b26801780d.tar.gz
gentoo-2-c42c3268acee611bc3f2d3c49aae38b26801780d.tar.bz2
gentoo-2-c42c3268acee611bc3f2d3c49aae38b26801780d.zip
Version bump.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xsnap')
-rw-r--r--x11-misc/xsnap/ChangeLog9
-rw-r--r--x11-misc/xsnap/xsnap-1.5.9.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/x11-misc/xsnap/ChangeLog b/x11-misc/xsnap/ChangeLog
index 3a752a731c57..97e28727192c 100644
--- a/x11-misc/xsnap/ChangeLog
+++ b/x11-misc/xsnap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xsnap
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/ChangeLog,v 1.39 2010/11/08 12:46:04 nelchael Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/ChangeLog,v 1.40 2011/11/15 22:04:31 jer Exp $
+
+*xsnap-1.5.9 (15 Nov 2011)
+
+ 15 Nov 2011; Jeroen Roovers <jer@gentoo.org> +xsnap-1.5.9.ebuild:
+ Version bump.
08 Nov 2010; Krzysztof Pawlik <nelchael@gentoo.org> xsnap-1.5.6.ebuild:
Change dependency: media-libs/jpeg -> virtual/jpeg.
diff --git a/x11-misc/xsnap/xsnap-1.5.9.ebuild b/x11-misc/xsnap/xsnap-1.5.9.ebuild
new file mode 100644
index 000000000000..37374e7796aa
--- /dev/null
+++ b/x11-misc/xsnap/xsnap-1.5.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/xsnap-1.5.9.ebuild,v 1.1 2011/11/15 22:04:31 jer Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Program to interactively take a 'snapshot' of a region of the screen"
+HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/Xutils/"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/Xutils/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ media-libs/libpng
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+ app-text/rman
+ x11-misc/imake"
+
+src_prepare() {
+ xmkmf || die
+ sed -i \
+ -e '/ CC = /d' \
+ -e '/ LD = /d' \
+ -e '/ CDEBUGFLAGS = /d' \
+ -e '/ CCOPTIONS = /d' \
+ -e 's|CPP = cpp|CPP = $(CC)|g' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+ dodoc README AUTHORS
+}