summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2011-05-31 08:15:38 +0000
committerCédric Krier <cedk@gentoo.org>2011-05-31 08:15:38 +0000
commit43842b7adb9cc8872f70630c26f2469e1c119293 (patch)
treeda3b503d63312de9d2ab99f7d560bf84ac61bea6 /x11-misc
parentChanged "opera" to "PN" in a comment. (diff)
downloadgentoo-2-43842b7adb9cc8872f70630c26f2469e1c119293.tar.gz
gentoo-2-43842b7adb9cc8872f70630c26f2469e1c119293.tar.bz2
gentoo-2-43842b7adb9cc8872f70630c26f2469e1c119293.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/dmenu/ChangeLog7
-rw-r--r--x11-misc/dmenu/dmenu-4.3.1.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-misc/dmenu/ChangeLog b/x11-misc/dmenu/ChangeLog
index b83aeffa9d91..0b72938e47a2 100644
--- a/x11-misc/dmenu/ChangeLog
+++ b/x11-misc/dmenu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/dmenu
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.67 2011/03/16 21:17:05 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/ChangeLog,v 1.68 2011/05/31 08:15:38 cedk Exp $
+
+*dmenu-4.3.1 (31 May 2011)
+
+ 31 May 2011; Cédric Krier <cedk@gentoo.org> +dmenu-4.3.1.ebuild:
+ Version bump
16 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> dmenu-4.2.1.ebuild:
ppc64 stable wrt #349630
diff --git a/x11-misc/dmenu/dmenu-4.3.1.ebuild b/x11-misc/dmenu/dmenu-4.3.1.ebuild
new file mode 100644
index 000000000000..8d08cffbdde1
--- /dev/null
+++ b/x11-misc/dmenu/dmenu-4.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dmenu/dmenu-4.3.1.ebuild,v 1.1 2011/05/31 08:15:38 cedk Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="a generic, highly customizable, and efficient menu for the X Window System"
+HOMEPAGE="http://www.suckless.org/programs/dmenu.html"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -ansi -pedantic -Wall -Os/CFLAGS += -ansi -pedantic -Wall -g/" \
+ -e "s/LDFLAGS = -s/LDFLAGS += -g/" \
+ -e "s/XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ if use xinerama; then
+ emake CC=$(tc-getCC) || die "emake failed"
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" \
+ || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ dodoc README
+}