summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-12 23:38:17 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-12 23:38:17 +0000
commit98b9a6b187cb064b670191b30b73c676101780c3 (patch)
treea730a8c43643b051bd059e95495b718eae47c086 /x11-misc
parentmask www-client/torbrowser (diff)
downloadgentoo-2-98b9a6b187cb064b670191b30b73c676101780c3.tar.gz
gentoo-2-98b9a6b187cb064b670191b30b73c676101780c3.tar.bz2
gentoo-2-98b9a6b187cb064b670191b30b73c676101780c3.zip
Version bump (thanks df, bug 415639)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfe/ChangeLog7
-rw-r--r--x11-misc/xfe/xfe-1.32.5.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index ec1f928dab10..ce6634356c3c 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xfe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.73 2012/03/02 19:45:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.74 2012/05/12 23:38:17 xmw Exp $
+
+*xfe-1.32.5 (12 May 2012)
+
+ 12 May 2012; Michael Weber <xmw@gentoo.org> +xfe-1.32.5.ebuild:
+ Version bump (thanks df, bug 415639)
02 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> -xfe-1.32.1.ebuild,
-files/xfe-1.32.1-inline.patch, -xfe-1.32.3.ebuild:
diff --git a/x11-misc/xfe/xfe-1.32.5.ebuild b/x11-misc/xfe/xfe-1.32.5.ebuild
new file mode 100644
index 000000000000..3f9e4865e6f5
--- /dev/null
+++ b/x11-misc/xfe/xfe-1.32.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.32.5.ebuild,v 1.1 2012/05/12 23:38:17 xmw Exp $
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="MS-Explorer-like minimalist file manager for X"
+HOMEPAGE="http://roland65.free.fr/xfe"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls startup-notification"
+
+RDEPEND="
+ media-libs/libpng:0
+ startup-notification? ( x11-libs/startup-notification )
+ x11-libs/fox:1.6[truetype,png]
+ x11-libs/libX11
+ x11-libs/libXft
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README TODO )
+PATCHES=( "${FILESDIR}"/${PN}-1.32.2-missing_Xlib_h.patch )
+
+src_prepare() {
+ base_src_prepare
+ cat >po/POTFILES.skip <<-EOF
+ src/icons.cpp
+ xfe.desktop.in.in
+ xfi.desktop.in.in
+ xfp.desktop.in.in
+ xfv.desktop.in.in
+ xfw.desktop.in.in
+ EOF
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable startup-notification sn) \
+ $(use_enable debug)
+}