summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2011-01-21 12:02:12 +0000
committerChristian Birchinger <joker@gentoo.org>2011-01-21 12:02:12 +0000
commit9925b49cbbcbc3a758b3ba01a00a6806cf45364f (patch)
tree53888c45f0ae76274de408e23b95aa6903d341a1 /x11-misc
parentApply lambda-bind patch. Bug #351998. Thanks to Sebastian Luther (few) <Sebas... (diff)
downloadgentoo-2-9925b49cbbcbc3a758b3ba01a00a6806cf45364f.tar.gz
gentoo-2-9925b49cbbcbc3a758b3ba01a00a6806cf45364f.tar.bz2
gentoo-2-9925b49cbbcbc3a758b3ba01a00a6806cf45364f.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdotool/ChangeLog10
-rw-r--r--x11-misc/xdotool/xdotool-2.20101012.3049.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/x11-misc/xdotool/ChangeLog b/x11-misc/xdotool/ChangeLog
index 5b7603f5ec0d..10d821c24ffc 100644
--- a/x11-misc/xdotool/ChangeLog
+++ b/x11-misc/xdotool/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xdotool
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.17 2010/10/29 21:52:42 joker Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/ChangeLog,v 1.18 2011/01/21 12:02:12 joker Exp $
+
+*xdotool-2.20101012.3049 (21 Jan 2011)
+
+ 21 Jan 2011; Christian Birchinger <joker@gentoo.org>
+ +xdotool-2.20101012.3049.ebuild:
+ Version bump
29 Oct 2010; Christian Birchinger <joker@gentoo.org>
xdotool-2.20100818.3004.ebuild:
diff --git a/x11-misc/xdotool/xdotool-2.20101012.3049.ebuild b/x11-misc/xdotool/xdotool-2.20101012.3049.ebuild
new file mode 100644
index 000000000000..27561c642855
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-2.20101012.3049.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdotool/xdotool-2.20101012.3049.ebuild,v 1.1 2011/01/21 12:02:12 joker Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows."
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="http://semicomplete.googlecode.com/files/${P}.tar.gz"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+DEPEND="x11-libs/libXtst
+ x11-libs/libX11"
+
+RDEPEND="${DEPEND}"
+
+# The test wants to manualy start Xvfb, wont use VirtualX and it tries
+# to run a full gnome-session. For such a tiny application i consider
+# it overkill to rewrite the test scripts to not use it's own X server
+# and add a full blown gnome just to run the tests.
+RESTRICT="test"
+
+src_prepare() {
+ sed -e "s/installheader post-install$/installheader/" \
+ -i Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC LD
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install || die
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}