summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-30 15:55:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-30 15:55:35 +0000
commitb388984dd061ba61159b69ee88291e882bebeb3a (patch)
treec60bfac5bbe7a87bc0732b65b2cf25c90ce491fc /x11-misc
parentremove old (diff)
downloadgentoo-2-b388984dd061ba61159b69ee88291e882bebeb3a.tar.gz
gentoo-2-b388984dd061ba61159b69ee88291e882bebeb3a.tar.bz2
gentoo-2-b388984dd061ba61159b69ee88291e882bebeb3a.zip
New snapshot with ebuild created by Julian Ospald
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/compton/ChangeLog8
-rw-r--r--x11-misc/compton/compton-0_pre20120330.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-misc/compton/ChangeLog b/x11-misc/compton/ChangeLog
index ba05a056b9d3..65e75f3fc27c 100644
--- a/x11-misc/compton/ChangeLog
+++ b/x11-misc/compton/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/compton
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/ChangeLog,v 1.1 2012/03/15 23:50:37 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/ChangeLog,v 1.2 2012/03/30 15:55:35 ssuominen Exp $
+
+*compton-0_pre20120330 (30 Mar 2012)
+
+ 30 Mar 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +compton-0_pre20120330.ebuild:
+ New snapshot with ebuild created by Julian Ospald
*compton-0_pre20120316 (15 Mar 2012)
diff --git a/x11-misc/compton/compton-0_pre20120330.ebuild b/x11-misc/compton/compton-0_pre20120330.ebuild
new file mode 100644
index 000000000000..c681e74711b4
--- /dev/null
+++ b/x11-misc/compton/compton-0_pre20120330.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/compton/compton-0_pre20120330.ebuild,v 1.1 2012/03/30 15:55:35 ssuominen Exp $
+
+EAPI=4
+
+unset _live_inherits
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/chjj/compton.git"
+ _live_inherits="git-2"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+fi
+
+inherit toolchain-funcs ${_live_inherits}
+
+DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
+HOMEPAGE="http://github.com/chjj/compton"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrender"
+RDEPEND="${COMMON_DEPEND}
+ app-shells/bash
+ x11-apps/xprop
+ x11-apps/xwininfo"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ tc-export CC
+}