summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-04-02 21:11:42 +0000
committerChristoph Mende <angelos@gentoo.org>2011-04-02 21:11:42 +0000
commitec23ccf5e1cdc08a08eab16dce4366b5d8f3fc5f (patch)
tree24b77387b480578244c0a71854a7f78ef6e5a4b8 /x11-misc
parentStable on amd64 wrt bug #358791 (diff)
downloadgentoo-2-ec23ccf5e1cdc08a08eab16dce4366b5d8f3fc5f.tar.gz
gentoo-2-ec23ccf5e1cdc08a08eab16dce4366b5d8f3fc5f.tar.bz2
gentoo-2-ec23ccf5e1cdc08a08eab16dce4366b5d8f3fc5f.zip
Initial import
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rodent/ChangeLog10
-rw-r--r--x11-misc/rodent/files/rodent-4.6.2-libs.patch12
-rw-r--r--x11-misc/rodent/metadata.xml7
-rw-r--r--x11-misc/rodent/rodent-4.6.2.ebuild32
4 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/rodent/ChangeLog b/x11-misc/rodent/ChangeLog
new file mode 100644
index 000000000000..11143b35e9db
--- /dev/null
+++ b/x11-misc/rodent/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/rodent
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rodent/ChangeLog,v 1.1 2011/04/02 21:11:42 angelos Exp $
+
+*rodent-4.6.2 (02 Apr 2011)
+
+ 02 Apr 2011; Christoph Mende <angelos@gentoo.org> +rodent-4.6.2.ebuild,
+ +files/rodent-4.6.2-libs.patch, +metadata.xml:
+ Initial import
+
diff --git a/x11-misc/rodent/files/rodent-4.6.2-libs.patch b/x11-misc/rodent/files/rodent-4.6.2-libs.patch
new file mode 100644
index 000000000000..086b7caac094
--- /dev/null
+++ b/x11-misc/rodent/files/rodent-4.6.2-libs.patch
@@ -0,0 +1,12 @@
+diff --git a/Build/lib/Makefile.am b/Build/lib/Makefile.am
+index 3f5f0aa..d60dfcc 100644
+--- a/Build/lib/Makefile.am
++++ b/Build/lib/Makefile.am
+@@ -160,6 +160,7 @@ libapplications_la_CFLAGS = $(common_CFLAGS) @LIBXML_CFLAGS@
+
+ COMMON_LDFLAGS = -export-dynamic -version-info @RFM_VERINFO@
+ librfm_la_LDFLAGS = $(COMMON_LDFLAGS)
++librfm_la_LIBADD = @LIBSM_LIBS@
+ librodent_la_LDFLAGS = $(COMMON_LDFLAGS)
+ librfm_deskview_la_LDFLAGS = $(COMMON_LDFLAGS)
+ librfm_gridview_la_LDFLAGS = $(COMMON_LDFLAGS)
diff --git a/x11-misc/rodent/metadata.xml b/x11-misc/rodent/metadata.xml
new file mode 100644
index 000000000000..237f5f649f23
--- /dev/null
+++ b/x11-misc/rodent/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>xfce</herd>
+<longdescription lang="en">Rodent is fast, small and powerful file manager for the GNU operating system (but it also works in BSD). Rodent is *not* a filemanager for dummies. Emphasis is on ease of use for the advanced user, not the computer illiterate.</longdescription>
+</pkgmetadata>
+
diff --git a/x11-misc/rodent/rodent-4.6.2.ebuild b/x11-misc/rodent/rodent-4.6.2.ebuild
new file mode 100644
index 000000000000..578549edca3b
--- /dev/null
+++ b/x11-misc/rodent/rodent-4.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/rodent/rodent-4.6.2.ebuild,v 1.1 2011/04/02 21:11:42 angelos Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="a fast, small and powerful file manager and graphical shell"
+HOMEPAGE="http://sourceforge.net/projects/xffm/"
+SRC_URI="mirror://sourceforge/project/xffm/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2:2
+ dev-libs/libzip
+ x11-libs/gtk+:2
+ x11-libs/libSM
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libs.patch
+ eautoreconf
+}