summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-11-12 11:11:11 +0000
committerMike Gardiner <obz@gentoo.org>2003-11-12 11:11:11 +0000
commit3888c5de2fa17f402d6875454bbc12575df0ea44 (patch)
tree93b71e61f94a858430ecf3ce0fa779cbaef034d9 /x11-plugins/desklet-weather/desklet-weather-0.22.ebuild
parentNew version as well as Sensors permission fix (diff)
downloadgentoo-2-3888c5de2fa17f402d6875454bbc12575df0ea44.tar.gz
gentoo-2-3888c5de2fa17f402d6875454bbc12575df0ea44.tar.bz2
gentoo-2-3888c5de2fa17f402d6875454bbc12575df0ea44.zip
New version as well as Sensors permission fix
Diffstat (limited to 'x11-plugins/desklet-weather/desklet-weather-0.22.ebuild')
-rw-r--r--x11-plugins/desklet-weather/desklet-weather-0.22.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-plugins/desklet-weather/desklet-weather-0.22.ebuild b/x11-plugins/desklet-weather/desklet-weather-0.22.ebuild
new file mode 100644
index 000000000000..980240ebeba9
--- /dev/null
+++ b/x11-plugins/desklet-weather/desklet-weather-0.22.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-weather/desklet-weather-0.22.ebuild,v 1.1 2003/11/12 11:11:00 obz Exp $
+
+DESKLET_NAME="Weather"
+
+MY_PN=${PN/desklet-/}-desklet
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A weather monitoring Sensor and Display for gdesklets"
+SRC_URI="http://gdesklets.gnomedesktop.org/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.pycage.de/"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND=">=gnome-extra/gdesklets-core-0.20"
+
+DOCS="INSTALL README"
+
+src_install( ) {
+
+ SYS_PATH="/usr/share/gdesklets"
+ INSTALL_BIN="Install_${DESKLET_NAME}_Sensor.bin"
+ dodir ${SYS_PATH}/{Sensors,Displays}
+
+ # first we install the Sensor
+ python ${INSTALL_BIN} --nomsg ${D}${SYS_PATH}/Sensors
+
+ # and then the .displays
+ insinto ${SYS_PATH}/Displays/${DESKLET_NAME}
+ doins *.display
+
+ # and finally the graphics
+ cp -R gfx/ ${D}${SYS_PATH}/Displays/${DESKLET_NAME}
+
+ dodoc ${DOCS}
+
+ # the desklets unpack preserves permissions of the archive
+ chown -R root:root ${D}${SYS_PATH}/Sensors/${DESKLET_NAME}
+
+}
+