summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2006-04-30 03:13:15 +0000
committerJory Pratt <anarchy@gentoo.org>2006-04-30 03:13:15 +0000
commit8c05454695eb8336d136a07c321714f22bc1d4d6 (patch)
tree4081e92cfc179483ed071fa1fb574ec2b4c37721 /x11-plugins/enigmail
parentversion bump (diff)
downloadgentoo-2-8c05454695eb8336d136a07c321714f22bc1d4d6.tar.gz
gentoo-2-8c05454695eb8336d136a07c321714f22bc1d4d6.tar.bz2
gentoo-2-8c05454695eb8336d136a07c321714f22bc1d4d6.zip
textrel fix introduced
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'x11-plugins/enigmail')
-rw-r--r--x11-plugins/enigmail/ChangeLog8
-rw-r--r--x11-plugins/enigmail/enigmail-0.94.0-r3.ebuild141
-rw-r--r--x11-plugins/enigmail/files/digest-enigmail-0.94.0-r39
3 files changed, 157 insertions, 1 deletions
diff --git a/x11-plugins/enigmail/ChangeLog b/x11-plugins/enigmail/ChangeLog
index 0d549866a335..17b78d3c4b47 100644
--- a/x11-plugins/enigmail/ChangeLog
+++ b/x11-plugins/enigmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/enigmail
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.14 2006/04/29 11:34:43 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.15 2006/04/30 03:13:14 anarchy Exp $
+
+*enigmail-0.94.0-r3 (30 Apr 2006)
+
+ 30 Apr 2006; Jory A. Pratt <anarchy@gentoo.org>
+ +enigmail-0.94.0-r3.ebuild:
+ textrel fix introduced
29 Apr 2006; Jory A. Pratt <anarchy@gentoo.org> enigmail-0.94.0-r2.ebuild:
stable wrt bug #130888
diff --git a/x11-plugins/enigmail/enigmail-0.94.0-r3.ebuild b/x11-plugins/enigmail/enigmail-0.94.0-r3.ebuild
new file mode 100644
index 000000000000..ee7dd61270a9
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-0.94.0-r3.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.94.0-r3.ebuild,v 1.1 2006/04/30 03:13:14 anarchy Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf makeedit multilib autotools
+
+EMVER=${PV}
+TBVER="1.5.0.2"
+TBPVER="1.3"
+
+DESCRIPTION="Gnupg encryption plugin for thunderbird."
+HOMEPAGE="http://www.enigmail.mozdev.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
+ mirror://gentoo/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
+ http://dev.gentoo.org/~anarchy/dist/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND=">=mail-client/mozilla-thunderbird-1.5"
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-1.4
+ >=www-client/mozilla-launcher-1.37"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ unpack thunderbird-${TBVER}-source.tar.bz2 mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2 || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ # Apply our patches
+ EPATCH_FORCE="yes" epatch ${WORKDIR}/patch
+
+ # Unpack the enigmail plugin
+ cd ${S}/mailnews/extensions || die
+ unpack enigmail-${EMVER}.tar.gz
+ cd ${S}/mailnews/extensions/enigmail || die "cd failed"
+ typeset m topdir
+ for m in $(find ../ -name Makefile.in); do
+ topdir=$(echo "$m" | sed -r 's:[^/]+:..:g')
+ sed -e "s:@srcdir@:.:g" -e "s:@top_srcdir@:${topdir}:g" \
+ < ${m} > ${m%.in} || die "sed ${m} failed"
+ done
+
+ cd ${S}
+
+ # Use the right theme for thunderbird #45609
+ sed -i -ne '/^enigmail-skin.jar:$/ { :x; n; /^\t/bx; }; p' mailnews/extensions/enigmail/ui/jar.mn
+
+ # Don't allow upgrades via the browser
+ epatch ${FILESDIR}/50_enigmail_no_upgrade-1.patch
+
+ # Fix installation of enigmail.js
+ epatch ${FILESDIR}/70_enigmail-fix.patch
+
+ eautoreconf || die "failed running autoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_annotate '' \
+ --with-system-nspr \
+ --with-system-nss \
+ --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # thunderbird
+ has_hardened && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Only build the parts necessary to support building enigmail
+ emake -j1 export || die "make export failed"
+ emake -C modules/libreg || die "make modules/libreg failed"
+ emake -C xpcom/string || die "make xpcom/string failed"
+ emake -C xpcom || die "make xpcom failed"
+ emake -C xpcom/obsolete || die "make xpcom/obsolete failed"
+
+ # Build the enigmail plugin
+ einfo "Building Enigmail plugin..."
+ emake -C ${S}/mailnews/extensions/enigmail || die "make enigmail failed"
+
+ # Package the enigmail plugin; this may be the easiest way to collect the
+ # necessary files
+ emake -j1 -C ${S}/mailnews/extensions/enigmail xpi || die "make xpi failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+ declare emid
+
+ cd ${T}
+ unzip ${S}/dist/bin/*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd ${D}${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip ${S}/dist/bin/*.xpi
+
+ # these files will be picked up by mozilla-launcher -register
+ dodir ${MOZILLA_FIVE_HOME}/{chrome,extensions}.d
+ insinto ${MOZILLA_FIVE_HOME}/chrome.d
+ newins ${S}/dist/bin/chrome/installed-chrome.txt ${PN}
+ echo "extension,${emid}" > ${D}${MOZILLA_FIVE_HOME}/extensions.d/${PN}
+}
diff --git a/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r3 b/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r3
new file mode 100644
index 000000000000..a62498d5345a
--- /dev/null
+++ b/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r3
@@ -0,0 +1,9 @@
+MD5 d326c302c1d2d68217fffcaa01ca7632 enigmail-0.94.0.tar.gz 508113
+RMD160 0fa8f0384b74623c1b84a048bdbf04bfca8c1824 enigmail-0.94.0.tar.gz 508113
+SHA256 db2b5fc014fe5efef95fc46804ac609616557b1696d5f355d2d7641e567904f3 enigmail-0.94.0.tar.gz 508113
+MD5 0647e319855808f50c5cb30a499ce48f mozilla-thunderbird-1.5.0.2-patches-1.3.tar.bz2 31424
+RMD160 a3e22fd8de4688e7e3ed513c86f6317cab9308b5 mozilla-thunderbird-1.5.0.2-patches-1.3.tar.bz2 31424
+SHA256 25a6d47859303fd2c1e49d6d81bb1b6c3c729e37bde43d4f277ef75902dbaa17 mozilla-thunderbird-1.5.0.2-patches-1.3.tar.bz2 31424
+MD5 3f32b847330c9d58297147be19714962 thunderbird-1.5.0.2-source.tar.bz2 35880369
+RMD160 8aaf02c205b131a38fa0384fe6126eec325c3e9e thunderbird-1.5.0.2-source.tar.bz2 35880369
+SHA256 d01a4edef782ea0d86e7ed5899ffdd48998211d5e134e3e93b1a0f9e56198151 thunderbird-1.5.0.2-source.tar.bz2 35880369