summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-04-26 22:46:43 +0000
committerJim Ramsay <lack@gentoo.org>2008-04-26 22:46:43 +0000
commit70cc7d6ddb04bc5c46eefc90e8de8b3ce8efe7ad (patch)
tree3a507555388320839f76d36de29032019500bdc0 /x11-plugins/gkrelltop
parentAdded an upstream patch to make k3b eject and re-load media correctly. Fixes ... (diff)
downloadgentoo-2-70cc7d6ddb04bc5c46eefc90e8de8b3ce8efe7ad.tar.gz
gentoo-2-70cc7d6ddb04bc5c46eefc90e8de8b3ce8efe7ad.tar.bz2
gentoo-2-70cc7d6ddb04bc5c46eefc90e8de8b3ce8efe7ad.zip
Version bump - 2.2.11 is released (bug #219006)
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins/gkrelltop')
-rw-r--r--x11-plugins/gkrelltop/ChangeLog9
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/x11-plugins/gkrelltop/ChangeLog b/x11-plugins/gkrelltop/ChangeLog
index 4cc6785cae68..56ebf0f5c731 100644
--- a/x11-plugins/gkrelltop/ChangeLog
+++ b/x11-plugins/gkrelltop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gkrelltop
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.25 2007/06/12 21:23:19 lack Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.26 2008/04/26 22:46:43 lack Exp $
+
+*gkrelltop-2.2.11 (26 Apr 2008)
+
+ 26 Apr 2008; Jim Ramsay <lack@gentoo.org> +gkrelltop-2.2.11.ebuild:
+ Version bump - 2.2.11 is released (bug #219006)
12 Jun 2007; Jim Ramsay <lack@gentoo.org> -gkrelltop-2.2.4.ebuild,
-gkrelltop-2.2.6.ebuild:
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild
new file mode 100644
index 000000000000..5d8919a304eb
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild,v 1.1 2008/04/26 22:46:43 lack Exp $
+
+inherit gkrellm-plugin
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/gkrelltop"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="X"
+
+PLUGIN_SERVER_SO=gkrelltopd.so
+PLUGIN_SO=gkrelltop.so
+
+S="${WORKDIR}/${P}.orig"
+
+DEPEND="=dev-libs/glib-2*
+ X? ( =x11-libs/gtk+-2* )"
+
+src_compile() {
+ econf
+ use X || TARGET="server"
+ emake ${TARGET}
+}
+
+pkg_postinst() {
+ einfo "To enable the gkrelltopd server plugin, you must add the following"
+ einfo "line to /etc/gkrellmd.conf:"
+ einfo "\tplugin-enable gkrelltopd"
+}