summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-22 21:25:35 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-22 21:25:35 +0000
commit7c73a1096cc9aa869ed546a72e4402259a954812 (patch)
tree3d207eeefe4fdbbc92c058509127bd9a851a9172 /x11-plugins/gkrelltop
parentinital ebuild (diff)
downloadgentoo-2-7c73a1096cc9aa869ed546a72e4402259a954812.tar.gz
gentoo-2-7c73a1096cc9aa869ed546a72e4402259a954812.tar.bz2
gentoo-2-7c73a1096cc9aa869ed546a72e4402259a954812.zip
inital ebuild
Diffstat (limited to 'x11-plugins/gkrelltop')
-rw-r--r--x11-plugins/gkrelltop/ChangeLog10
-rw-r--r--x11-plugins/gkrelltop/Manifest3
-rw-r--r--x11-plugins/gkrelltop/files/digest-gkrelltop-2.21
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.ebuild30
4 files changed, 43 insertions, 1 deletions
diff --git a/x11-plugins/gkrelltop/ChangeLog b/x11-plugins/gkrelltop/ChangeLog
new file mode 100644
index 000000000000..1cc5329f6f0e
--- /dev/null
+++ b/x11-plugins/gkrelltop/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-plugins/gkrelltop
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/ChangeLog,v 1.1 2003/10/22 21:25:30 mholzer Exp $
+
+*gkrelltop-2.2 (23 Oct 2003)
+
+ 23 Oct 2003; Martin Holzer <mholzer@gentoo.org> gkrelltop-2.2.ebuild:
+ initial ebuild. submitted by Ciaran McCreesh <ciaranm@firedrop.org.uk> in
+ #29382.
+
diff --git a/x11-plugins/gkrelltop/Manifest b/x11-plugins/gkrelltop/Manifest
index 0405cb5616e0..bc868463a9fd 100644
--- a/x11-plugins/gkrelltop/Manifest
+++ b/x11-plugins/gkrelltop/Manifest
@@ -1,2 +1,3 @@
-MD5 5622362dd457b03496b34de23ed2a258 gkrelltop-2.2.ebuild 945
+MD5 9ed7242ca96c7d4817d6150e552cfaab gkrelltop-2.2.ebuild 1051
+MD5 b6b2fc0312bc0598c98daeba75f16cf4 ChangeLog 414
MD5 bc19088e1d88db5e98e5f821f27f94f3 files/digest-gkrelltop-2.2 61
diff --git a/x11-plugins/gkrelltop/files/digest-gkrelltop-2.2 b/x11-plugins/gkrelltop/files/digest-gkrelltop-2.2
new file mode 100644
index 000000000000..5731a60b0272
--- /dev/null
+++ b/x11-plugins/gkrelltop/files/digest-gkrelltop-2.2
@@ -0,0 +1 @@
+MD5 fbddff14365fd81afa9e97dd919fcf6c gkrelltop.2.2.tgz 33435
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.ebuild
new file mode 100644
index 000000000000..f3c4214766a3
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrelltop/gkrelltop-2.2.ebuild,v 1.1 2003/10/22 21:25:30 mholzer Exp $
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="http://psychology.rutgers.edu/~zaimi/${PN}.${PV}.tgz"
+HOMEPAGE="http://psychology.rutgers.edu/~zaimi/software.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="=app-admin/gkrellm-2*"
+
+src_compile() {
+ # Unfortunately, the supplied Makefile won't work properly on
+ # non-x86, so we have to do this the hard way.
+ CONFIG="-DLINUX -DGKRELLM2 -fPIC `pkg-config gtk+-2.0 --cflags`"
+ LIBS="`pkg-config gtk+-2.0 --libs` -shared"
+ OBJS="top_three2.o gkrelltop2.o"
+ gcc -c $CONFIG $CFLAGS top_three.c -o top_three2.o || die
+ gcc -c $CONFIG $CFLAGS gkrelltop.c -o gkrelltop2.o || die
+ gcc $LIBS $CONFIG $CFLAGS -o gkrelltop2.so $OBJS || die
+}
+
+src_install() {
+ dodoc README
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrelltop2.so
+}