summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-25 20:50:51 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-25 20:50:51 +0000
commit6c0d99caaf0f9cdbb66ea2cb9ff3b821d3b3a76a (patch)
treeb9dc4c1edf2d26dc3efa5a0de180fad1ae0ae85b /x11-plugins/wmbiff/wmbiff-0.4.25.ebuild
parentadd macos keyword (diff)
downloadgentoo-2-6c0d99caaf0f9cdbb66ea2cb9ff3b821d3b3a76a.tar.gz
gentoo-2-6c0d99caaf0f9cdbb66ea2cb9ff3b821d3b3a76a.tar.bz2
gentoo-2-6c0d99caaf0f9cdbb66ea2cb9ff3b821d3b3a76a.zip
Bump x11-plugins/wmbiff version to 0.4.25, closing #57965. Wipe out older ebuilds.
Diffstat (limited to 'x11-plugins/wmbiff/wmbiff-0.4.25.ebuild')
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.25.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.25.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.25.ebuild
new file mode 100644
index 000000000000..a6c6c03cbba4
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.25.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.25.ebuild,v 1.1 2004/07/25 20:50:51 s4t4n Exp $
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes."
+SRC_URI="mirror://sourceforge/wmbiff/${P}.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/wmbiff/"
+
+DEPEND="virtual/x11
+ crypt? ( >=net-libs/gnutls-1.0.4
+ >=dev-libs/libgcrypt-1.1.94 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE="crypt"
+
+#This has been fixed upstream
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+# if use crypt; then
+# if has_version ">dev-libs/libgcrypt-1.1.12"; then
+# epatch ${FILESDIR}/${P}-crypto-api-fix.patch
+# fi
+# fi
+#}
+
+src_compile() {
+ local myconf
+ if ! use crypt; then
+ myconf="--disable-crypto"
+ fi
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog FAQ NEWS README README.licq TODO wmbiff/sample.wmbiffrc
+}