summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-31 22:41:36 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-31 22:41:36 +0000
commit73b9511fb920b33dfb4cbf4b256f718af75ebe8a (patch)
treed212a3c062ccad3bab7238d24d7bbb5ac7f6b3a0 /x11-plugins/wmdrawer/wmdrawer-0.10.5.ebuild
parentfix description & homepage (Manifest recommit) (diff)
downloadgentoo-2-73b9511fb920b33dfb4cbf4b256f718af75ebe8a.tar.gz
gentoo-2-73b9511fb920b33dfb4cbf4b256f718af75ebe8a.tar.bz2
gentoo-2-73b9511fb920b33dfb4cbf4b256f718af75ebe8a.zip
Bump x11-plugins/wmdrawer to version 0.10.5. Version 0.10.4.1 stable for x86. Remove older ebuilds. Fix DEPEND in existing ebuilds.
Diffstat (limited to 'x11-plugins/wmdrawer/wmdrawer-0.10.5.ebuild')
-rw-r--r--x11-plugins/wmdrawer/wmdrawer-0.10.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/wmdrawer/wmdrawer-0.10.5.ebuild b/x11-plugins/wmdrawer/wmdrawer-0.10.5.ebuild
new file mode 100644
index 000000000000..6ca7a58d66d0
--- /dev/null
+++ b/x11-plugins/wmdrawer/wmdrawer-0.10.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdrawer/wmdrawer-0.10.5.ebuild,v 1.1 2004/07/31 22:41:36 s4t4n Exp $
+
+IUSE=""
+DESCRIPTION="wmDrawer is a dock application (dockapp) which provides a drawer (retractable button bar) to launch applications"
+SRC_URI="http://people.easter-eggs.org/~valos/wmdrawer/${P}.tar.gz"
+HOMEPAGE="http://people.easter-eggs.org/~valos/wmdrawer/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc"
+
+DEPEND="virtual/x11
+ >=media-libs/gdk-pixbuf-0.22.0
+ >=app-arch/gzip-1.3.3-r4"
+
+src_compile()
+{
+ emake CFLAGS="${CFLAGS} -Wall `gdk-pixbuf-config --cflags`" \
+ || die "make failed!"
+}
+
+src_install()
+{
+ dobin wmdrawer
+ dodoc COPYING INSTALL README TODO AUTHORS ChangeLog wmdrawerrc.example
+ gzip -cd doc/wmdrawer.1x.gz > wmdrawer.1
+ doman wmdrawer.1
+}