summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-29 14:11:34 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-29 14:11:34 +0000
commit4578468d6629c01030a3762e0c6ef9825ada2746 (patch)
tree0052246f4666e388038e3048830544919c2b71d4 /x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
parentStable on ppc wrt bug 215121 (diff)
downloadgentoo-2-4578468d6629c01030a3762e0c6ef9825ada2746.tar.gz
gentoo-2-4578468d6629c01030a3762e0c6ef9825ada2746.tar.bz2
gentoo-2-4578468d6629c01030a3762e0c6ef9825ada2746.zip
quoting
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc3 x86_64)
Diffstat (limited to 'x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild')
-rw-r--r--x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild45
1 files changed, 19 insertions, 26 deletions
diff --git a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
index 85c0a2a7698d..1a576cb9fa28 100644
--- a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
+++ b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild
@@ -1,21 +1,22 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild,v 1.6 2007/07/22 05:06:09 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmgrabimage/wmgrabimage-0.72-r1.ebuild,v 1.7 2008/06/29 14:11:34 drac Exp $
inherit eutils
-IUSE=""
-
MY_P=${PN/grabi/GrabI}
-S=${WORKDIR}/${MY_P}-${PV}/${MY_P}
DESCRIPTION="wmGrabImage grabs an image from the WWW and displays it"
SRC_URI="http://www.dockapps.com/download.php/id/19/${MY_P}-${PV}.tgz"
HOMEPAGE="http://www.dockapps.com/file.php/id/12"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
RDEPEND=">=net-misc/wget-1.9-r2
>=media-gfx/imagemagick-5.5.7.15
- >=sys-apps/sed-4
x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
@@ -23,36 +24,28 @@ DEPEND="${RDEPEND}
x11-proto/xproto
x11-proto/xextproto"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc"
+S=${WORKDIR}/${MY_P}-${PV}/${MY_P}
-src_unpack()
-{
+src_unpack() {
unpack ${A}
-
- cd ${S}
- epatch ${FILESDIR}/${PN}-noman.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-noman.patch
+ sed -i -e 's/-geom /-geometry /' GrabImage || die "sed failed."
}
-src_compile()
-{
- sed -i -e 's/-geom /-geometry /' GrabImage
- emake clean || die "clean failed"
- emake CFLAGS="${CFLAGS} -Wall" || die "make failed"
+src_compile() {
+ emake clean || die "emake clean failed."
+ emake CFLAGS="${CFLAGS} -Wall" || die "emake failed."
}
-src_install()
-{
- cd ${S}
+src_install() {
dodir /usr/bin
- einstall DESTDIR="${D}/usr" || die "make install failed"
+ einstall DESTDIR="${D}/usr" || die "einstall failed."
doman wmGrabImage.1
- cd ..
- dodoc BUGS CHANGES HINTS TODO
+ dodoc ../{BUGS,CHANGES,HINTS,TODO}
insinto /usr/share/applications
- doins ${FILESDIR}/${PN}.desktop
+ doins "${FILESDIR}"/${PN}.desktop
}