summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-20 15:53:35 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-20 15:53:35 +0000
commit3cc5fc80c5e4921ebbb00354eb17851cc3580434 (patch)
treeadd02a8a9cf975ded3b13cdacb99b47dd2ef6b6c /x11-plugins/wmmon+smp
parentDrop Darwin patch as it does not apply cleanly and it is already in newer ver... (diff)
downloadgentoo-2-3cc5fc80c5e4921ebbb00354eb17851cc3580434.tar.gz
gentoo-2-3cc5fc80c5e4921ebbb00354eb17851cc3580434.tar.bz2
gentoo-2-3cc5fc80c5e4921ebbb00354eb17851cc3580434.zip
Modernize ebuild
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'x11-plugins/wmmon+smp')
-rw-r--r--x11-plugins/wmmon+smp/ChangeLog10
-rw-r--r--x11-plugins/wmmon+smp/metadata.xml4
-rw-r--r--x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild39
3 files changed, 49 insertions, 4 deletions
diff --git a/x11-plugins/wmmon+smp/ChangeLog b/x11-plugins/wmmon+smp/ChangeLog
index 3cf912d225de..cd183b456245 100644
--- a/x11-plugins/wmmon+smp/ChangeLog
+++ b/x11-plugins/wmmon+smp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmmon+smp
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon+smp/ChangeLog,v 1.11 2010/08/30 15:52:58 s4t4n Exp $
+# Copyright 2002-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon+smp/ChangeLog,v 1.12 2015/03/20 15:53:35 jlec Exp $
+
+*wmmon+smp-1.0-r2 (20 Mar 2015)
+
+ 20 Mar 2015; Justin Lecher <jlec@gentoo.org> +wmmon+smp-1.0-r2.ebuild,
+ metadata.xml:
+ Modernize ebuild
30 Aug 2010; Michele Noberasco <s4t4n@gentoo.org>; wmmon+smp-1.0-r1.ebuild:
Respect LDFLAGS, see bug #335047.
diff --git a/x11-plugins/wmmon+smp/metadata.xml b/x11-plugins/wmmon+smp/metadata.xml
index 82cba0084a89..c19c35269035 100644
--- a/x11-plugins/wmmon+smp/metadata.xml
+++ b/x11-plugins/wmmon+smp/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>desktop-dock</herd>
-<longdescription>
+ <herd>desktop-dock</herd>
+ <longdescription>
WMMon+SMP shows real-time CPU usage on SMP machines. Only Dual-processor
systems are supported. A load average graph a.k.a. wmloadavg/xload is also
provided. WMMon+SMP is based on WMMon 1.0b2 and does not display I/O or memory
diff --git a/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild
new file mode 100644
index 000000000000..99c115c55911
--- /dev/null
+++ b/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmon+smp/wmmon+smp-1.0-r2.ebuild,v 1.1 2015/03/20 15:53:35 jlec Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockapp CPU monitor resembling Xosview, support for smp"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/wmmon+smp.tar.gz"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/wmmon.app/wmmon
+
+src_prepare() {
+ # Respect LDFLAGS, see bug #335047
+ sed \
+ -e 's/cc -o/${CC} ${LDFLAGS} -o/' \
+ -e 's/cc -c/${CC} ${CFLAGS} -c/' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install () {
+ newbin wmmon wmmon+smp
+ dodoc ../README
+}