summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Leitch <port001@gentoo.org>2003-12-26 18:03:14 +0000
committerIan Leitch <port001@gentoo.org>2003-12-26 18:03:14 +0000
commitb462a10edf8ff0c0ee3f1eb682c800113cad69bc (patch)
treec2ea2428da79e1a2883c2dca04bc12da9115930d /x11-plugins/wmpager/wmpager-1.2-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-b462a10edf8ff0c0ee3f1eb682c800113cad69bc.tar.gz
gentoo-2-b462a10edf8ff0c0ee3f1eb682c800113cad69bc.tar.bz2
gentoo-2-b462a10edf8ff0c0ee3f1eb682c800113cad69bc.zip
Moved from x11-misc to x11-plugins
Diffstat (limited to 'x11-plugins/wmpager/wmpager-1.2-r1.ebuild')
-rw-r--r--x11-plugins/wmpager/wmpager-1.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/wmpager/wmpager-1.2-r1.ebuild b/x11-plugins/wmpager/wmpager-1.2-r1.ebuild
new file mode 100644
index 000000000000..d52ed5cb5f2a
--- /dev/null
+++ b/x11-plugins/wmpager/wmpager-1.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpager/wmpager-1.2-r1.ebuild,v 1.1 2003/12/26 18:03:05 port001 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A simple pager docklet for the WindowMaker window manager."
+HOMEPAGE="http://wmpager.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wmpager/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4"
+
+RDEPEND="virtual/x11
+ virtual/glibc"
+
+src_compile() {
+ sed -i "s:\(WMPAGER_DEFAULT_INSTALL_DIR \).*:\1\"/usr/share/wmpager\":" \
+ src/wmpager.c
+
+ emake || die
+}
+
+src_install() {
+ make INSTALLDIR=${D}/usr install || die
+
+ rm -rf ${D}/usr/man
+ doman man/man1/*.1x
+ dodoc README
+}