summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:38:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:38:55 +0000
commit3e95c3a47657e7811c16c07af04c794a9057e1b8 (patch)
tree05d6c6c6eb4ebdeb52ea05bf2b22f6365cfc2af9 /x11-plugins
parentarm stable, bug #497760 (diff)
downloadgentoo-2-3e95c3a47657e7811c16c07af04c794a9057e1b8.tar.gz
gentoo-2-3e95c3a47657e7811c16c07af04c794a9057e1b8.tar.bz2
gentoo-2-3e95c3a47657e7811c16c07af04c794a9057e1b8.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmpasman/ChangeLog8
-rw-r--r--x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild20
-rw-r--r--x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild15
3 files changed, 17 insertions, 26 deletions
diff --git a/x11-plugins/wmpasman/ChangeLog b/x11-plugins/wmpasman/ChangeLog
index 29213dcd0740..59b57ea008ea 100644
--- a/x11-plugins/wmpasman/ChangeLog
+++ b/x11-plugins/wmpasman/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmpasman
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/ChangeLog,v 1.14 2012/10/02 12:48:02 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/ChangeLog,v 1.15 2014/04/07 19:38:55 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmpasman-0.8.4.1.ebuild,
+ wmpasman-0.8.5.3.ebuild:
+ Use EAPI5 instead of EAPI1.
*wmpasman-0.8.5.3 (02 Oct 2012)
diff --git a/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild b/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
index 8ae7ef086624..3f05c3767d58 100644
--- a/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
+++ b/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild,v 1.11 2012/05/05 05:12:03 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/wmpasman-0.8.4.1.ebuild,v 1.12 2014/04/07 19:38:55 ssuominen Exp $
-EAPI="1"
+EAPI=5
DESCRIPTION="Password storage/retrieval in a dockapp"
HOMEPAGE="http://sourceforge.net/projects/wmpasman/"
@@ -21,19 +21,13 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
>=x11-libs/libXpm-3.5.5"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Solves compile error about undefined exit - Bug 140857
- sed -i -e '/#include <stdio.h>/ { p ; s/stdio/stdlib/ }' wmgeneral/wmgeneral-gtk.c
+ sed -i -e '/#include <stdio.h>/ { p ; s/stdio/stdlib/ }' wmgeneral/wmgeneral-gtk.c || die
}
src_install() {
- einstall || die "einstall failed."
+ # TODO: einstall is deprecated, convert to emake with args
+ einstall
dodoc BUGS ChangeLog README TODO WARNINGS
}
-
-pkg_postinst() {
- ewarn "Please read the WARNINGS file."
-}
diff --git a/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild b/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild
index e5496be1ed38..7fb1e7751188 100644
--- a/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild
+++ b/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild,v 1.1 2012/10/02 12:48:02 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpasman/wmpasman-0.8.5.3.ebuild,v 1.2 2014/04/07 19:38:55 ssuominen Exp $
-EAPI=4
+EAPI=5
DESCRIPTION="Password storage/retrieval in a dockapp"
HOMEPAGE="http://sourceforge.net/projects/wmpasman/"
@@ -21,11 +21,4 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
>=x11-libs/libXpm-3.5.5"
-src_install() {
- emake DESTDIR="${D}" install
- dodoc BUGS ChangeLog README TODO WARNINGS
-}
-
-pkg_postinst() {
- ewarn "Please read the WARNINGS file."
-}
+DOCS="BUGS ChangeLog README TODO WARNINGS"