summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-29 19:34:57 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-29 19:34:57 +0000
commit4f4d6fe0e2050af49f11f2d6265094451ab85701 (patch)
tree40592008aa7cd6feadb8cfa992758f34dc1e845d /x11-plugins
parentRemove old. (diff)
downloadgentoo-2-4f4d6fe0e2050af49f11f2d6265094451ab85701.tar.gz
gentoo-2-4f4d6fe0e2050af49f11f2d6265094451ab85701.tar.bz2
gentoo-2-4f4d6fe0e2050af49f11f2d6265094451ab85701.zip
version bump, fix header
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-opensteamworks/ChangeLog10
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p36.ebuild4
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild41
3 files changed, 51 insertions, 4 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/ChangeLog b/x11-plugins/pidgin-opensteamworks/ChangeLog
index 1a690ebf8acf..f3304f097efb 100644
--- a/x11-plugins/pidgin-opensteamworks/ChangeLog
+++ b/x11-plugins/pidgin-opensteamworks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-opensteamworks
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.11 2012/12/10 18:31:29 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.12 2013/01/29 19:34:57 hasufell Exp $
+
+*pidgin-opensteamworks-1.0_p38 (29 Jan 2013)
+
+ 29 Jan 2013; Julian Ospald <hasufell@gentoo.org>
+ +pidgin-opensteamworks-1.0_p38.ebuild:
+ version bump
10 Dec 2012; Agostino Sarubbo <ago@gentoo.org>
pidgin-opensteamworks-1.0_p36.ebuild:
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p36.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p36.ebuild
index e70005915427..142029877986 100644
--- a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p36.ebuild
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p36.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p36.ebuild,v 1.4 2012/12/10 18:31:29 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p36.ebuild,v 1.5 2013/01/29 19:34:57 hasufell Exp $
EAPI=4
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild
new file mode 100644
index 000000000000..a7255512e690
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild,v 1.1 2013/01/29 19:34:57 hasufell Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Steam protocol plugin for pidgin"
+HOMEPAGE="http://code.google.com/p/pidgin-opensteamworks/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+ http://pidgin-opensteamworks.googlecode.com/files/icons.zip
+ -> ${PN}-icons.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ net-im/pidgin"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ # see http://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
+ cp "${FILESDIR}"/${PN}-1.0_p32-Makefile "${S}"/Makefile || die
+}
+
+src_install() {
+ default
+ insinto /usr/share/pixmaps/pidgin/protocols
+ doins -r "${WORKDIR}"/{16,48}
+}