summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-07-11 22:06:05 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-07-11 22:06:05 +0000
commit93cb478263eb317731b154b28b1c679ade822c83 (patch)
treec6d967ec147edfa7e706cd09309ff8f737340d79 /x11-plugins
parentVersion bump. (diff)
downloadgentoo-2-93cb478263eb317731b154b28b1c679ade822c83.tar.gz
gentoo-2-93cb478263eb317731b154b28b1c679ade822c83.tar.bz2
gentoo-2-93cb478263eb317731b154b28b1c679ade822c83.zip
Fix ~arch version to support new windowmaker
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/fsviewer/ChangeLog6
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch36
-rw-r--r--x11-plugins/fsviewer/fsviewer-0.2.5.ebuild5
-rw-r--r--x11-plugins/fsviewer/fsviewer-0.2.6.ebuild19
4 files changed, 56 insertions, 10 deletions
diff --git a/x11-plugins/fsviewer/ChangeLog b/x11-plugins/fsviewer/ChangeLog
index 98e8c1e7473c..4a2bcea1ec92 100644
--- a/x11-plugins/fsviewer/ChangeLog
+++ b/x11-plugins/fsviewer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/fsviewer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/ChangeLog,v 1.20 2012/06/14 15:43:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/ChangeLog,v 1.21 2012/07/11 22:06:05 voyageur Exp $
+
+ 11 Jul 2012; Bernard Cafarelli <voyageur@gentoo.org> fsviewer-0.2.5.ebuild,
+ fsviewer-0.2.6.ebuild, +files/fsviewer-0.2.6-wmaker-0.95_support.patch:
+ Fix ~arch version to support new windowmaker
14 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> fsviewer-0.2.5.ebuild:
x11-libs/libPropList rename to x11-libs/libproplist
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
new file mode 100644
index 000000000000..da64f3a0389e
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
@@ -0,0 +1,36 @@
+diff -Naur fsviewer-app-0.2.6.orig/configure.ac fsviewer-app-0.2.6/configure.ac
+--- fsviewer-app-0.2.6.orig/configure.ac 2012-07-11 17:55:06.448981246 +0200
++++ fsviewer-app-0.2.6/configure.ac 2012-07-11 18:04:15.528940159 +0200
+@@ -81,6 +81,8 @@
+ AC_MSG_ERROR([WMaker library not found]))
+ AC_CHECK_LIB(WINGs, WMAppSetMainMenu,,
+ AC_MSG_ERROR([WINGs library not found]))
++AC_CHECK_LIB(WUtil, WMCreatePLString,,
++ AC_MSG_ERROR([WUtil library not found]))
+
+ dnl Checks for PropList (not necessary since version 0.2.3b)
+ dnl AC_CHECK_HEADERS(proplist.h,, AC_MSG_WARN(Can't find PropList include-file: Please install libPropList (included in WindowMaker)))
+diff -Naur fsviewer-app-0.2.6.orig/defs/chdef.c fsviewer-app-0.2.6/defs/chdef.c
+--- fsviewer-app-0.2.6.orig/defs/chdef.c 2012-07-11 17:55:06.444981361 +0200
++++ fsviewer-app-0.2.6/defs/chdef.c 2012-07-11 17:55:50.387699640 +0200
+@@ -374,7 +374,7 @@
+ SetIntegerForKey(0, "DisplayMCListPixmap");
+
+ WMWritePropListToFile(filesDB,
+- wdefaultspathfordomain("FSViewer"), True);
++ wdefaultspathfordomain("FSViewer"));
+ result = 0;
+ }
+ else
+diff -Naur fsviewer-app-0.2.6.orig/src/extnInspector.c fsviewer-app-0.2.6/src/extnInspector.c
+--- fsviewer-app-0.2.6.orig/src/extnInspector.c 2012-07-11 17:55:06.452981130 +0200
++++ fsviewer-app-0.2.6/src/extnInspector.c 2012-07-11 17:56:02.315351669 +0200
+@@ -229,7 +229,7 @@
+
+ if(numRows > 0)
+ WMWritePropListToFile(filesDB,
+- wdefaultspathfordomain("FSViewer"), True);
++ wdefaultspathfordomain("FSViewer"));
+
+ if(extn)
+ free(extn);
diff --git a/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild b/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild
index 2dd33d684a03..37b41c961187 100644
--- a/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild
+++ b/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild,v 1.12 2012/06/14 15:43:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild,v 1.13 2012/07/11 22:06:05 voyageur Exp $
EAPI=1
@@ -40,7 +40,8 @@ DEPEND="
x11-libs/libXt
x11-proto/xextproto
x11-proto/xproto
- x11-wm/windowmaker"
+ <x11-wm/windowmaker-0.95.0"
+RDEPEND=${DEPEND}
S=${WORKDIR}/${MY_PN}.app-${PV}
diff --git a/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild b/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
index e82b2ee75830..daa9d786fd0a 100644
--- a/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
+++ b/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild,v 1.1 2010/06/26 23:42:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild,v 1.2 2012/07/11 22:06:05 voyageur Exp $
-EAPI=2
-inherit multilib
+EAPI=4
+inherit autotools eutils multilib
MY_P=${PN}-app-${PV}
@@ -16,7 +16,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="nls"
-RDEPEND="x11-wm/windowmaker
+RDEPEND=">=x11-wm/windowmaker-0.95.2
x11-libs/libXft
x11-libs/libXpm
x11-libs/libX11"
@@ -26,14 +26,19 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wmaker-0.95_support.patch
+ eautoreconf
+}
+
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable nls) \
--with-appspath=/usr/$(get_libdir)/GNUstep
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
+ dosym /usr/$(get_libdir)/GNUstep/FSViewer.app/FSViewer /usr/bin/FSViewer
dodoc AUTHORS ChangeLog NEWS README
}