summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 09:04:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 09:04:13 +0000
commita29beea997f882b043881daa368dd7f2fc091cc0 (patch)
tree369b9d337def6ac32931a609b63a1070383bfb77 /x11-plugins
parentx86 stable wrt bug #353039 (diff)
downloadgentoo-2-a29beea997f882b043881daa368dd7f2fc091cc0.tar.gz
gentoo-2-a29beea997f882b043881daa368dd7f2fc091cc0.tar.bz2
gentoo-2-a29beea997f882b043881daa368dd7f2fc091cc0.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-libnotify/ChangeLog9
-rw-r--r--x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch18
-rw-r--r--x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild18
3 files changed, 34 insertions, 11 deletions
diff --git a/x11-plugins/pidgin-libnotify/ChangeLog b/x11-plugins/pidgin-libnotify/ChangeLog
index 9c63f8f435d6..26df2d990b90 100644
--- a/x11-plugins/pidgin-libnotify/ChangeLog
+++ b/x11-plugins/pidgin-libnotify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/pidgin-libnotify
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/ChangeLog,v 1.22 2010/07/22 20:19:32 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/ChangeLog,v 1.23 2011/01/30 09:04:13 ssuominen Exp $
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+ pidgin-libnotify-0.14.ebuild,
+ +files/pidgin-libnotify-0.14-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
22 Jul 2010; Peter Volkov <pva@gentoo.org> pidgin-libnotify-0.14.ebuild:
Don't build static libs: for plugins they are useless, bug #327237, thank
diff --git a/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch b/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch
new file mode 100644
index 000000000000..40e6c02b8152
--- /dev/null
+++ b/x11-plugins/pidgin-libnotify/files/pidgin-libnotify-0.14-libnotify-0.7.patch
@@ -0,0 +1,18 @@
+--- src/pidgin-libnotify.c
++++ src/pidgin-libnotify.c
+@@ -286,7 +286,15 @@
+ g_free (tr_body);
+ return;
+ }
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notification = notify_notification_new (title, tr_body, NULL);
++#else
+ notification = notify_notification_new (title, tr_body, NULL, NULL);
++#endif
++#else
++ notification = notify_notification_new (title, tr_body, NULL, NULL);
++#endif
+ purple_debug_info (PLUGIN_ID, "notify(), new: "
+ "title: '%s', body: '%s', buddy: '%s'\n",
+ title, tr_body, best_name (buddy));
diff --git a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild
index c802e4bc8aed..26d991abad9c 100644
--- a/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild
+++ b/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild,v 1.7 2010/07/22 20:19:32 pva Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-libnotify/pidgin-libnotify-0.14.ebuild,v 1.8 2011/01/30 09:04:13 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="pidgin-libnotify provides popups for pidgin via a libnotify interface"
@@ -17,13 +16,14 @@ IUSE="nls debug"
RDEPEND=">=x11-libs/libnotify-0.3.2
net-im/pidgin[gtk]
- >=x11-libs/gtk+-2"
-
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/pidgin-libnotify-showbutton.patch
+ epatch \
+ "${FILESDIR}"/pidgin-libnotify-showbutton.patch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
}
src_configure() {
@@ -34,7 +34,7 @@ src_configure() {
}
src_install() {
- emake install DESTDIR="${D}" || die "make install failed"
+ emake install DESTDIR="${D}" || die
find "${D}" -name '*.la' -delete
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO VERSION || die
+ dodoc AUTHORS ChangeLog NEWS README TODO VERSION || die
}