summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:17:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:17:33 +0000
commitd1339f7964acf9bf332dfe72a568a21532006b20 (patch)
tree21b32140962b629f20ba90a85d929c64bdda7c33 /x11-plugins
parentFix building with x11-libs/libnotify >= 0.7 wrt #352128 by Priit Laes. (diff)
downloadgentoo-2-d1339f7964acf9bf332dfe72a568a21532006b20.tar.gz
gentoo-2-d1339f7964acf9bf332dfe72a568a21532006b20.tar.bz2
gentoo-2-d1339f7964acf9bf332dfe72a568a21532006b20.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmudmount/ChangeLog8
-rw-r--r--x11-plugins/wmudmount/files/wmudmount-1.8-libnotify-0.7.patch16
-rw-r--r--x11-plugins/wmudmount/wmudmount-1.8.ebuild12
3 files changed, 31 insertions, 5 deletions
diff --git a/x11-plugins/wmudmount/ChangeLog b/x11-plugins/wmudmount/ChangeLog
index a99989acfa6b..437d4fa66f49 100644
--- a/x11-plugins/wmudmount/ChangeLog
+++ b/x11-plugins/wmudmount/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmudmount
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.4 2010/12/26 13:01:52 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/ChangeLog,v 1.5 2011/01/29 14:17:33 ssuominen Exp $
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> wmudmount-1.8.ebuild,
+ +files/wmudmount-1.8-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
*wmudmount-1.8 (26 Dec 2010)
diff --git a/x11-plugins/wmudmount/files/wmudmount-1.8-libnotify-0.7.patch b/x11-plugins/wmudmount/files/wmudmount-1.8-libnotify-0.7.patch
new file mode 100644
index 000000000000..eaae8604d7ce
--- /dev/null
+++ b/x11-plugins/wmudmount/files/wmudmount-1.8-libnotify-0.7.patch
@@ -0,0 +1,16 @@
+--- notify.c
++++ notify.c
+@@ -58,7 +58,12 @@
+ } else if(G_IS_FILE_ICON(icon)){
+ icon_name = g_icon_to_string(icon);
+ }
+- NotifyNotification *n = notify_notification_new(summary, body, icon_name, NULL);
++ NotifyNotification *n = notify_notification_new(summary, body, icon_name
++#ifdef HAVE_LIBNOTIFY_07
++ );
++#else
++ , NULL);
++#endif
+ GError *err = NULL;
+ if(!notify_notification_show(n, &err)){
+ warn(DEBUG_ERROR, "Failed to show notification \"%s\" \"%s\": %s", summary, body, err?err->message:"<unknown error>");
diff --git a/x11-plugins/wmudmount/wmudmount-1.8.ebuild b/x11-plugins/wmudmount/wmudmount-1.8.ebuild
index 4848cbd97e56..ce5d373bd8bb 100644
--- a/x11-plugins/wmudmount/wmudmount-1.8.ebuild
+++ b/x11-plugins/wmudmount/wmudmount-1.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-1.8.ebuild,v 1.1 2010/12/26 13:01:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmudmount/wmudmount-1.8.ebuild,v 1.2 2011/01/29 14:17:33 ssuominen Exp $
EAPI=2
-inherit gnome2-utils
+inherit flag-o-matic gnome2-utils
DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
HOMEPAGE="http://sourceforge.net/projects/wmudmount/"
@@ -22,7 +22,13 @@ RDEPEND=">=x11-libs/gtk+-2.18:2
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
+
src_configure() {
+ has_version ">=x11-libs/libnotify-0.7" && append-cppflags -DHAVE_LIBNOTIFY_07
+
econf \
--disable-dependency-tracking \
$(use_with libnotify) \