summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:41:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:41:35 +0000
commitdbe5b9bed07b2883eb0a1567cb1ec5c8ade32745 (patch)
tree6580bdc1456fcdc734d7b9f6c9ba806665a873ff /x11-plugins
parentarm stable, bug #503014 (diff)
downloadgentoo-2-dbe5b9bed07b2883eb0a1567cb1ec5c8ade32745.tar.gz
gentoo-2-dbe5b9bed07b2883eb0a1567cb1ec5c8ade32745.tar.bz2
gentoo-2-dbe5b9bed07b2883eb0a1567cb1ec5c8ade32745.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfishtime/ChangeLog8
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild13
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild12
3 files changed, 18 insertions, 15 deletions
diff --git a/x11-plugins/wmfishtime/ChangeLog b/x11-plugins/wmfishtime/ChangeLog
index bbf06e429203..e2667d0205b4 100644
--- a/x11-plugins/wmfishtime/ChangeLog
+++ b/x11-plugins/wmfishtime/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmfishtime
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/ChangeLog,v 1.28 2012/05/05 05:12:00 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/ChangeLog,v 1.29 2014/04/07 19:41:35 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmfishtime-1.24-r1.ebuild,
+ wmfishtime-1.24-r2.ebuild:
+ Use EAPI5 instead of EAPI1.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wmfishtime-1.24-r1.ebuild,
wmfishtime-1.24-r2.ebuild:
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
index 4a6084b7aa89..ee57a8a0b1bd 100644
--- a/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild,v 1.8 2012/05/05 05:12:00 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r1.ebuild,v 1.9 2014/04/07 19:41:35 ssuominen Exp $
+EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
@@ -20,14 +19,12 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-gtk.patch
}
src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed."
+ emake CC="$(tc-getCC)"
}
src_install() {
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
index da9a5f569de9..4f554ff45240 100644
--- a/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild,v 1.6 2012/05/05 05:12:00 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild,v 1.7 2014/04/07 19:41:35 ssuominen Exp $
-EAPI=4
+EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
@@ -20,8 +20,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gtk.patch
- epatch "${FILESDIR}"/${P}-no_display.patch
+ epatch \
+ "${FILESDIR}"/${P}-gtk.patch \
+ "${FILESDIR}"/${P}-no_display.patch
+
sed -i -e "s/\$(CC)/& \$(LDFLAGS)/" Makefile || die #331891
}