summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-09-11 15:52:37 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-09-11 15:52:37 +0000
commit6bf08460347e4407e54c9299bc3865d6249061ff (patch)
tree96b72c99487eda4b09970b66ff8c4686a3894db5 /x11-terms/gnome-terminal
parentWarning instead of dying when USE="-x264 x265-static" (diff)
downloadgentoo-2-6bf08460347e4407e54c9299bc3865d6249061ff.tar.gz
gentoo-2-6bf08460347e4407e54c9299bc3865d6249061ff.tar.bz2
gentoo-2-6bf08460347e4407e54c9299bc3865d6249061ff.zip
Partial Fix for bug 268846 -- gnome-terminal errors out when no dbus-daemon is running. Upstream not interested in a complete fix.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'x11-terms/gnome-terminal')
-rw-r--r--x11-terms/gnome-terminal/ChangeLog10
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-2.26.3.1-partial-fix-dbus-error.patch75
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r2.ebuild (renamed from x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r1.ebuild)6
3 files changed, 89 insertions, 2 deletions
diff --git a/x11-terms/gnome-terminal/ChangeLog b/x11-terms/gnome-terminal/ChangeLog
index 64fc19d439ca..125efef50c4a 100644
--- a/x11-terms/gnome-terminal/ChangeLog
+++ b/x11-terms/gnome-terminal/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-terms/gnome-terminal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.200 2009/09/06 12:57:38 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/ChangeLog,v 1.201 2009/09/11 15:52:36 nirbheek Exp $
+
+*gnome-terminal-2.26.3.1-r2 (11 Sep 2009)
+
+ 11 Sep 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ -gnome-terminal-2.26.3.1-r1.ebuild, +gnome-terminal-2.26.3.1-r2.ebuild,
+ +files/gnome-terminal-2.26.3.1-partial-fix-dbus-error.patch:
+ Partial Fix for bug 268846 -- gnome-terminal errors out when no
+ dbus-daemon is running. Upstream not interested in a complete fix.
06 Sep 2009; Gilles Dartiguelongue <eva@gentoo.org>
-gnome-terminal-2.26.1.ebuild, gnome-terminal-2.26.2.ebuild,
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-2.26.3.1-partial-fix-dbus-error.patch b/x11-terms/gnome-terminal/files/gnome-terminal-2.26.3.1-partial-fix-dbus-error.patch
new file mode 100644
index 000000000000..b6945651eb5f
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-2.26.3.1-partial-fix-dbus-error.patch
@@ -0,0 +1,75 @@
+Partial fix for Gentoo bug 268846, upstream is not interested in a complete fix
+that allows gnome-terminal to work when gconf-daemon cannot be run.
+
+--
+From f41c3d14bdfd533109d7d75bdbb2e2a0ab59b60c Mon Sep 17 00:00:00 2001
+From: Christian Persch <chpe@gnome.org>
+Date: Thu, 13 Aug 2009 12:31:11 +0000
+Subject: Be more lenient in the gconf daemon check
+
+Using gconf_ping_daemon() wasn't working right, since it returns FALSE
+not only when the gconf daemon cannot be spawned, but also if the daemon
+simply isn't running yet, but could be started without problems. Use
+gconf_spawn_daemon() instead. Should fix problem reported in bug 564649
+comment 5.
+---
+diff --git a/src/terminal.c b/src/terminal.c
+index 41285e5..fc0cb2b 100644
+--- a/src/terminal.c
++++ b/src/terminal.c
+@@ -236,8 +236,8 @@ get_factory_name_for_display (const char *display_name)
+ }
+
+ /* Evil hack alert: this is exported from libgconf-2 but not in a public header */
+-extern gboolean gconf_ping_daemon (void);
+-
++extern gboolean gconf_spawn_daemon(GError** err);
++
+ int
+ main (int argc, char **argv)
+ {
+@@ -329,7 +329,7 @@ main (int argc, char **argv)
+ {
+ g_printerr ("Failed to get the session bus: %s\nFalling back to non-factory mode.\n",
+ error->message);
+- g_error_free (error);
++ g_clear_error (&error);
+ goto factory_disabled;
+ }
+
+@@ -353,7 +353,7 @@ main (int argc, char **argv)
+ &error))
+ {
+ g_printerr ("Failed name request: %s\n", error->message);
+- g_error_free (error);
++ g_clear_error (&error);
+ goto factory_disabled;
+ }
+
+@@ -419,7 +419,7 @@ main (int argc, char **argv)
+ {
+ /* Incompatible factory version, fall back, to new instance */
+ g_printerr (_("Incompatible factory version; creating a new instance.\n"));
+- g_error_free (error);
++ g_clear_error (&error);
+
+ goto factory_disabled;
+ }
+@@ -449,10 +449,13 @@ factory_disabled:
+ /* If the gconf daemon isn't available (e.g. because there's no dbus
+ * session bus running), we'd crash later on. Tell the user about it
+ * now, and exit. See bug #561663.
++ * Don't use gconf_ping_daemon() here since the server may just not
++ * be running yet, but able to be started. See comments on bug #564649.
+ */
+- if (!gconf_ping_daemon ())
++ if (!gconf_spawn_daemon (&error))
+ {
+- g_printerr ("Failed to contact the GConf daemon; exiting.\n");
++ g_printerr ("Failed to summon the GConf demon: %s\n", error->message);
++ g_error_free (error);
+ exit (1);
+ }
+
+--
+cgit v0.8.2
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r1.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r2.ebuild
index b94693732563..95cca0c6a298 100644
--- a/x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r1.ebuild
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r1.ebuild,v 1.2 2009/09/06 12:57:38 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/gnome-terminal/gnome-terminal-2.26.3.1-r2.ebuild,v 1.1 2009/09/11 15:52:36 nirbheek Exp $
inherit eutils gnome2
@@ -45,6 +45,10 @@ src_unpack() {
# in user on /, fix bug #269318, import from upstream bug #565328.
epatch "${FILESDIR}"/${P}-cwd-on-new-tab.patch
+ # Fix bug 268846 -- gnome-terminal errors out if it can't find the gconf
+ # daemon. Patch is from upstream git repository, included in 2.28
+ epatch "${FILESDIR}"/${P}-partial-fix-dbus-error.patch
+
# patch gnome terminal to report as GNOME rather than xterm
# This needs to resolve a few bugs (#120294,)
# Leave out for now; causing too many problems