summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2008-05-03 12:55:04 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2008-05-03 12:55:04 +0000
commitdc99457cda14f249191abfbbda3dea488547053a (patch)
tree17ac0a80907db6fdbabafb7379e4110f9cfcf96f /x11-terms/rxvt/rxvt-2.7.10-r4.ebuild
parentVersion bump. (diff)
downloadgentoo-2-dc99457cda14f249191abfbbda3dea488547053a.tar.gz
gentoo-2-dc99457cda14f249191abfbbda3dea488547053a.tar.bz2
gentoo-2-dc99457cda14f249191abfbbda3dea488547053a.zip
revbump to include a patch to fix CVE-2008-1142 (do not default to :0 if DISPLAY is unset), bug 217819; stable on amd64
(Portage version: 2.1.5_rc6, RepoMan options: --force)
Diffstat (limited to 'x11-terms/rxvt/rxvt-2.7.10-r4.ebuild')
-rw-r--r--x11-terms/rxvt/rxvt-2.7.10-r4.ebuild98
1 files changed, 98 insertions, 0 deletions
diff --git a/x11-terms/rxvt/rxvt-2.7.10-r4.ebuild b/x11-terms/rxvt/rxvt-2.7.10-r4.ebuild
new file mode 100644
index 000000000000..c9fdda923d61
--- /dev/null
+++ b/x11-terms/rxvt/rxvt-2.7.10-r4.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.10-r4.ebuild,v 1.1 2008/05/03 12:55:03 hoffie Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="rxvt -- nice small x11 terminal"
+HOMEPAGE="http://rxvt.sourceforge.net/
+ http://www.giga.it.okayama-u.ac.jp/~ishihara/opensource/"
+SRC_URI="mirror://sourceforge/rxvt/${P}.tar.gz
+ http://www.giga.it.okayama-u.ac.jp/~ishihara/opensource/${P}-xim-fix.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="motif cjk xgetdefault linuxkeys"
+
+RDEPEND="virtual/libc
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext
+ motif? ( x11-libs/openmotif )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-line-scroll.patch
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ use motif && epatch "${FILESDIR}"/${P}-azz4.diff
+ if use cjk ; then
+ epatch "${DISTDIR}"/${P}-xim-fix.patch.gz
+ if use linguas_ja ; then
+ epatch "${FILESDIR}"/${P}-rk.patch
+ fi
+ fi
+
+ epatch "${FILESDIR}"/${P}-CVE-2008-1142-DISPLAY.patch
+ elibtoolize
+}
+
+src_compile() {
+
+ local term
+ if [ -n "${RXVT_TERM}" ] ; then
+ term="${RXVT_TERM}"
+ else
+ term="rxvt"
+ fi
+
+ # bug #22325
+ use linuxkeys && append-flags -DLINUX_KEYS
+
+ econf \
+ --enable-everything \
+ --enable-rxvt-scroll \
+ --enable-next-scroll \
+ --enable-xterm-scroll \
+ --enable-transparency \
+ --enable-xpm-background \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-mousewheel \
+ --enable-slipwheeling \
+ --enable-smart-resize \
+ --enable-256-color \
+ --enable-menubar \
+ $(use_enable cjk languages) \
+ --enable-xim \
+ --enable-shared \
+ --enable-keepscrolling \
+ --with-term=${term} \
+ $(use_enable xgetdefault) || die
+
+ emake || die
+}
+
+src_install() {
+
+ einstall mandir="${D}"/usr/share/man/man1 || die
+
+ cd "${S}"/doc
+ dodoc README* *.txt BUGS FAQ
+ dohtml *.html
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "If you want to change default TERM variable other than rxvt,"
+ einfo "set RXVT_TERM environment variable and then emerge rxvt."
+ einfo "Especially, if you use rxvt under monochrome X you might need to run"
+ einfo "\t RXVT_TERM=rxvt-basic emerge rxvt"
+ einfo "otherwise curses based program will not work."
+ einfo
+}