summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-04-04 19:47:28 +0000
committerJoe McCann <joem@gentoo.org>2005-04-04 19:47:28 +0000
commit5d4a87338006d0aa4968c2792614316a24c0bd3e (patch)
treec5ebfcbcf92aa1dace296fe9fa31f4e78d97e2ac /x11-themes
parentFixed BUG #82060. (diff)
downloadgentoo-2-5d4a87338006d0aa4968c2792614316a24c0bd3e.tar.gz
gentoo-2-5d4a87338006d0aa4968c2792614316a24c0bd3e.tar.bz2
gentoo-2-5d4a87338006d0aa4968c2792614316a24c0bd3e.zip
Add gtk-update-icon-cache to postinst so we can create a cache and load icons faster
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-themes/ChangeLog6
-rw-r--r--x11-themes/gnome-themes/gnome-themes-2.10.0.ebuild20
2 files changed, 23 insertions, 3 deletions
diff --git a/x11-themes/gnome-themes/ChangeLog b/x11-themes/gnome-themes/ChangeLog
index 998931be34fb..0596af18e0a5 100644
--- a/x11-themes/gnome-themes/ChangeLog
+++ b/x11-themes/gnome-themes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-themes/gnome-themes
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes/ChangeLog,v 1.73 2005/04/02 03:32:22 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes/ChangeLog,v 1.74 2005/04/04 19:47:28 joem Exp $
+
+ 04 Apr 2005; Joe McCann <joem@gentoo.org> gnome-themes-2.10.0.ebuild:
+ Add gtk-update-icon-cache to postinst so we can create a cache and load
+ icons faster
02 Apr 2005; Stephen P. Becker <geoman@gentoo.org>
gnome-themes-2.8.1.ebuild:
diff --git a/x11-themes/gnome-themes/gnome-themes-2.10.0.ebuild b/x11-themes/gnome-themes/gnome-themes-2.10.0.ebuild
index b266c8ef9f69..4c7955e4c675 100644
--- a/x11-themes/gnome-themes/gnome-themes-2.10.0.ebuild
+++ b/x11-themes/gnome-themes/gnome-themes-2.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes/gnome-themes-2.10.0.ebuild,v 1.1 2005/03/09 06:39:27 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes/gnome-themes-2.10.0.ebuild,v 1.2 2005/04/04 19:47:28 joem Exp $
# FIXME : the engines in here should probably be disabled and done in seperate ebuilds
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="accessibility"
-RDEPEND=">=x11-libs/gtk+-2
+RDEPEND=">=x11-libs/gtk+-2.6
>=x11-themes/gtk-engines-2.5"
DEPEND=">=dev-util/pkgconfig-0.12.0
@@ -22,3 +22,19 @@ DEPEND=">=dev-util/pkgconfig-0.12.0
G2CONF="${G2CONF} $(use_enable accessibility all-themes)"
DOCS="AUTHORS README NEWS ChangeLog"
+
+pkg_postinst() {
+ einfo "Updating Icon Cache"
+
+ if use accessibility; then
+ gtk-update-icon-cache -qf /usr/share/icons/LowContrastLargePrint
+ gtk-update-icon-cache -qf /usr/share/icons/HighContrastLargePrint
+ gtk-update-icon-cache -qf /usr/share/icons/HighContrastLargePrintInverse
+ fi
+
+ gtk-update-icon-cache -qf /usr/share/icons/Crux
+ gtk-update-icon-cache -qf /usr/share/icons/Flat-Blue
+ gtk-update-icon-cache -qf /usr/share/icons/Sandy
+ gtk-update-icon-cache -qf /usr/share/icons/Smokey-Blue
+ gtk-update-icon-cache -qf /usr/share/icons/Smokey-Red
+}