summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-01-27 20:56:55 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-01-27 20:56:55 +0000
commitb5bc37c69c40e28f84f52fe132aeee54e4d44360 (patch)
tree7a4361b2957e4118d16012c6f2e197f7457c0c16 /x11-themes
parentVersion bump (diff)
downloadgentoo-2-b5bc37c69c40e28f84f52fe132aeee54e4d44360.tar.gz
gentoo-2-b5bc37c69c40e28f84f52fe132aeee54e4d44360.tar.bz2
gentoo-2-b5bc37c69c40e28f84f52fe132aeee54e4d44360.zip
Properly fix #41576 this time (#79756).
(Portage version: 2.0.51-r15)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/mandrake-artwork/mandrake-artwork-1.0.2.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/x11-themes/mandrake-artwork/mandrake-artwork-1.0.2.ebuild b/x11-themes/mandrake-artwork/mandrake-artwork-1.0.2.ebuild
index d3e4164b677b..3b7dd32ce11f 100644
--- a/x11-themes/mandrake-artwork/mandrake-artwork-1.0.2.ebuild
+++ b/x11-themes/mandrake-artwork/mandrake-artwork-1.0.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/mandrake-artwork/mandrake-artwork-1.0.2.ebuild,v 1.6 2005/01/26 16:12:44 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/mandrake-artwork/mandrake-artwork-1.0.2.ebuild,v 1.7 2005/01/27 20:56:55 greg_g Exp $
-inherit eutils kde
+inherit eutils kde-functions
MDK_EXTRAVERSION="1mdk"
@@ -22,8 +22,6 @@ RDEPEND=">=x11-libs/gtk+-2.0
DEPEND="${RDEPEND}
app-arch/rpm2targz"
-need-kde 3.1
-
src_unpack() {
rpm2targz ${DISTDIR}/${A}
tar xz --no-same-owner -f galaxy-${PV}-${MDK_EXTRAVERSION}.src.tar.gz
@@ -37,11 +35,12 @@ src_compile() {
#epatch ${FILESDIR}/galaxy-gtk24.patch
if use kde; then
- KDE_PLACE_TO_INSTALL=$(echo $KDEDIR | cut -d/ -f4)
+ set-qtdir 3
+ set-kdedir 3
mv thememdk/mandrake_client/Makefile.in thememdk/mandrake_client/Makefile.in.orig
- cat thememdk/mandrake_client/Makefile.in.orig | sed s:\$\{libdir\}\/kwin.la:/usr/kde/$KDE_PLACE_TO_INSTALL/lib/kwin.la:g > thememdk/mandrake_client/Makefile.in
+ cat thememdk/mandrake_client/Makefile.in.orig | sed s:\$\{libdir\}\/kwin.la:${KDEDIR}/lib/kwin.la:g > thememdk/mandrake_client/Makefile.in
rm thememdk/mandrake_client/Makefile.in.orig
- econf --with-qt-dir=/usr/qt/3 || die "econf failed"
+ econf --with-qt-dir=${QTDIR} || die "econf failed"
else
sed -si s/KDE_CHECK_FINAL// configure.in
sed -si s/AC_PATH_KDE// configure.in