summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-10-04 02:47:32 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-10-04 02:47:32 +0000
commiteac8d6a507bc9838aeb12a956b3bff8d981591cc (patch)
tree2d2712f0df71339661f464d91be0a5eae8c7880e /x11-themes
parentAdded ~sparc keyword. (Manifest recommit) (diff)
downloadgentoo-2-eac8d6a507bc9838aeb12a956b3bff8d981591cc.tar.gz
gentoo-2-eac8d6a507bc9838aeb12a956b3bff8d981591cc.tar.bz2
gentoo-2-eac8d6a507bc9838aeb12a956b3bff8d981591cc.zip
Update to install properly for xfree or xorg-x11, add virtual/x11 to RDEPEND.
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/redhat-artwork/ChangeLog7
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild18
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.95.ebuild18
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.96.ebuild6
4 files changed, 31 insertions, 18 deletions
diff --git a/x11-themes/redhat-artwork/ChangeLog b/x11-themes/redhat-artwork/ChangeLog
index 117f2b0d3ed4..d53b9cef95aa 100644
--- a/x11-themes/redhat-artwork/ChangeLog
+++ b/x11-themes/redhat-artwork/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/redhat-artwork
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/ChangeLog,v 1.37 2004/09/05 09:57:50 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/ChangeLog,v 1.38 2004/10/04 02:47:32 spyderous Exp $
+
+ 03 Oct 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ redhat-artwork-0.73.ebuild, redhat-artwork-0.95.ebuild,
+ redhat-artwork-0.96.ebuild:
+ Update to install properly for xfree or xorg-x11, add virtual/x11 to RDEPEND.
05 Sep 2004; Sven Wegener <swegener@gentoo.org> :
Fixed ChangeLog header.
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild
index 9e6e4185308b..7b9afd84a47c 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild,v 1.14 2004/07/13 20:30:29 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.73.ebuild,v 1.15 2004/10/04 02:47:32 spyderous Exp $
inherit eutils rpm
@@ -25,8 +25,8 @@ DEPEND=">=sys-devel/autoconf-2.58
>=kde-base/kdebase-3.0.2 )
gtk2? ( >=x11-libs/gtk+-2* )"
# Because one may only want to use the theme with kde OR gtk OR Metacity
-# OR gdm, we don't want any run-time dependencies...
-RDEPEND=""
+# OR gdm, we don't want either as run-time dependencies...
+RDEPEND="virtual/x11"
# We need to change some RedHat-specific stuff to Gentoo-style...
_replace() {
@@ -164,11 +164,15 @@ src_install () {
sed -e 's|Screenshot=|#Screenshot=|' GdmGreeterTheme.desktop > GdmGreeterTheme.desktop.mod
mv GdmGreeterTheme.desktop.mod GdmGreeterTheme.desktop
- # move cursors to /usr/share/cursors/xfree
+ # move cursors to /usr/share/cursors/${X11_IMPL}
+ X11_IMPLEM_P="$(portageq best_version ${ROOT} virtual/x11)"
+ X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
+ X11_IMPLEM="${X11_IMPLEM##*\/}"
+
for x in Bluecurve Bluecurve-inverse; do
- dodir /usr/share/cursors/xfree/${x}
- mv ${D}/usr/share/icons/${x}/cursors ${D}/usr/share/cursors/xfree/${x}
- dosym /usr/share/cursors/xfree/${x}/cursors /usr/share/icons/${x}/cursors
+ dodir /usr/share/cursors/${X11_IMPLEM}/${x}
+ mv ${D}/usr/share/icons/${x}/cursors ${D}/usr/share/cursors/${X11_IMPLEM}/${x}
+ dosym /usr/share/cursors/${X11_IMPLEM}/${x}/cursors /usr/share/icons/${x}/cursors
done
# remove xmms skin if unneeded
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.95.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.95.ebuild
index 08bc925b07d0..f211f5a4594b 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.95.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.95.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.95.ebuild,v 1.7 2004/07/07 16:58:50 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.95.ebuild,v 1.8 2004/10/04 02:47:32 spyderous Exp $
inherit eutils rpm
@@ -26,8 +26,8 @@ DEPEND=">=sys-devel/autoconf-2.58
>=kde-base/kdebase-3.0.2 )
gtk2? ( >=x11-libs/gtk+-2* )"
# Because one may only want to use the theme with kde OR gtk OR Metacity
-# OR gdm, we don't want any run-time dependencies...
-RDEPEND=""
+# OR gdm, we don't want either as run-time dependencies...
+RDEPEND="virtual/x11"
# We need to change some RedHat-specific stuff to Gentoo-style...
_replace() {
@@ -162,11 +162,15 @@ src_install () {
sed -e 's|Screenshot=|#Screenshot=|' GdmGreeterTheme.desktop > GdmGreeterTheme.desktop.mod
mv GdmGreeterTheme.desktop.mod GdmGreeterTheme.desktop
- # move cursors to /usr/share/cursors/xfree
+ # move cursors to /usr/share/cursors/${X11_IMPL}
+ X11_IMPLEM_P="$(portageq best_version ${ROOT} virtual/x11)"
+ X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
+ X11_IMPLEM="${X11_IMPLEM##*\/}"
+
for x in Bluecurve Bluecurve-inverse; do
- dodir /usr/share/cursors/xfree/${x}
- mv ${D}/usr/share/icons/${x}/cursors ${D}/usr/share/cursors/xfree/${x}
- dosym /usr/share/cursors/xfree/${x}/cursors /usr/share/icons/${x}/cursors
+ dodir /usr/share/cursors/${X11_IMPLEM}/${x}
+ mv ${D}/usr/share/icons/${x}/cursors ${D}/usr/share/cursors/${X11_IMPLEM}/${x}
+ dosym /usr/share/cursors/${X11_IMPLEM}/${x}/cursors /usr/share/icons/${x}/cursors
done
# remove xmms skin if unneeded
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.96.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.96.ebuild
index 65bd45a62e9c..55e34c9d3ead 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.96.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.96.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.96.ebuild,v 1.5 2004/08/13 22:34:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.96.ebuild,v 1.6 2004/10/04 02:47:32 spyderous Exp $
inherit eutils rpm
@@ -26,8 +26,8 @@ DEPEND=">=sys-devel/autoconf-2.58
>=kde-base/kdebase-3.0.2 )
gtk2? ( >=x11-libs/gtk+-2* )"
# Because one may only want to use the theme with kde OR gtk OR Metacity
-# OR gdm, we don't want any run-time dependencies...
-RDEPEND=""
+# OR gdm, we don't want either as run-time dependencies...
+RDEPEND="virtual/x11"
# We need to change some RedHat-specific stuff to Gentoo-style...
_replace() {