summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-03 15:44:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-03 15:44:39 +0000
commit36dbd34fad30343bb1ac70787ed5d7f3aa54f86b (patch)
tree8eca3a34dda3bb71c231579a860ab96274c6a1ff /x11-wm/WindowMaker
parentmasked KDE 3.0.2 for testing, arggg (diff)
downloadgentoo-2-36dbd34fad30343bb1ac70787ed5d7f3aa54f86b.tar.gz
gentoo-2-36dbd34fad30343bb1ac70787ed5d7f3aa54f86b.tar.bz2
gentoo-2-36dbd34fad30343bb1ac70787ed5d7f3aa54f86b.zip
Taiwanese translations restored with patch
Diffstat (limited to 'x11-wm/WindowMaker')
-rw-r--r--x11-wm/WindowMaker/ChangeLog14
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.80.1-r1.ebuild146
-rw-r--r--x11-wm/WindowMaker/files/WindowMaker-0.81-gentoo.patch109
-rw-r--r--x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r12
4 files changed, 268 insertions, 3 deletions
diff --git a/x11-wm/WindowMaker/ChangeLog b/x11-wm/WindowMaker/ChangeLog
index 3e17c2575c7c..453de2c43bae 100644
--- a/x11-wm/WindowMaker/ChangeLog
+++ b/x11-wm/WindowMaker/ChangeLog
@@ -1,11 +1,19 @@
# ChangeLog for x11-wm/WindowMaker
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/ChangeLog,v 1.9 2002/07/02 16:50:36 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/ChangeLog,v 1.10 2002/07/03 15:44:39 seemant Exp $
+
+*WindowMaker-0.80.1-r1 (03 Jul 2002)
+
+ 03 Jul 2002; Seemant Kulleen <seemant@gentoo.org>
+ WindowMaker-0.80.1-r1.ebuild files/digest-WindowMaker-0.80.1-r1 :
+
+ lwj <lwj@manufacture.com.tw> the upstream developer for Taiwanese
+ translations gave us a patch to make it compile and install correctly.
*WindowMaker-0.80.1 (02 Jul 2002)
- 02 Jul 2002; Seemant Kulleen <seemant@gentoo.org> WindowMaker-0.80.1.ebuild
- files/digest-WindowMaker-0.80.1 :
+ 02 Jul 2002; Seemant Kulleen <seemant@gentoo.org> WindowMaker-0.80.1.ebuild
+ files/digest-WindowMaker-0.80.1 :
Version bump. Removed Taiwanese translations installation.
diff --git a/x11-wm/WindowMaker/WindowMaker-0.80.1-r1.ebuild b/x11-wm/WindowMaker/WindowMaker-0.80.1-r1.ebuild
new file mode 100644
index 000000000000..88b2830ae00a
--- /dev/null
+++ b/x11-wm/WindowMaker/WindowMaker-0.80.1-r1.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.80.1-r1.ebuild,v 1.1 2002/07/03 15:44:39 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window Maker"
+SRC_URI="ftp://ftp.windowmaker.org/pub/source/release/${P}.tar.gz
+ ftp://ftp.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+HOMEPAGE="http://www.windowmaker.org/"
+
+DEPEND="virtual/x11
+ >=media-libs/tiff-3.5.5
+ x11-wm/gnustep-env
+ gif? ( >=media-libs/giflib-4.1.0-r3
+ >=media-libs/libungif-4.1.0 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )"
+
+RDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+#NOTE: the default menu has the wrong path for the WMPrefs utility.
+# Needs fixing.
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+
+ patch -p1 < ${FILESDIR}/wmfpo-80.patch
+
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ && export KDEDIR=/usr/kde/2 \
+ || myconf="${myconf} --disable-kde"
+
+ if [ "$WITH_MODELOCK" ] ; then
+ myconf="${myconf} --enable-modelock"
+ else
+ myconf="${myconf} --disable-modelock"
+ fi
+
+ use nls \
+ && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`" \
+ || myconf="${myconf} --disable-nls --disable-locale"
+
+ use gif \
+ || myconf="${myconf} --disable-gif"
+
+ use jpeg \
+ || myconf="${myconf} --disable-jpeg"
+
+ use png \
+ || myconf="${myconf} --disable-png"
+
+
+ use esd || use alsa || use oss \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/X11 \
+ --with-x \
+ --enable-newstyle \
+ --enable-superfluous \
+ --enable-usermenu \
+ ${myconf} || die
+
+ cd ${S}/po
+ cp Makefile Makefile.orig
+ sed 's:zh_TW.*::' \
+ Makefile.orig > Makefile
+
+ cd ${S}/WPrefs.app/po
+ cp Makefile Makefile.orig
+ sed 's:zh_TW.*::' \
+ Makefile.orig > Makefile
+
+ cd ${S}
+ emake || die
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/X11 \
+ GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
+ install || die
+
+ cp -f WindowMaker/plmenu ${D}/etc/X11/WindowMaker/WMRootMenu
+
+ dodoc AUTHORS BUGFORUM BUGS ChangeLog COPYING* INSTALL* FAQ* \
+ MIRRORS README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ newdoc README README.extra
+
+ echo "#!/bin/bash" > wmaker
+ echo "/usr/bin/wmaker" >> wmaker
+
+ exeino /etc/X11/Sessions/
+ doexe wmaker
+}
+
+pkg_postinst() {
+
+ echo
+ echo '######################################################################'
+ echo '# If do you want trans globes and other trans elements do you need #'
+ echo '# the libxpm (media-libs/xpm). #'
+ echo '######################################################################'
+ }
+
diff --git a/x11-wm/WindowMaker/files/WindowMaker-0.81-gentoo.patch b/x11-wm/WindowMaker/files/WindowMaker-0.81-gentoo.patch
new file mode 100644
index 000000000000..7db52d4a0a47
--- /dev/null
+++ b/x11-wm/WindowMaker/files/WindowMaker-0.81-gentoo.patch
@@ -0,0 +1,109 @@
+diff -urN WindowMaker-0.80.1.old/WPrefs.app/po/zh_TW.Big5.po WindowMaker-0.80.1/WPrefs.app/po/zh_TW.Big5.po
+--- WindowMaker-0.80.1.old/WPrefs.app/po/zh_TW.Big5.po Tue Jan 8 05:44:42 2002
++++ WindowMaker-0.80.1/WPrefs.app/po/zh_TW.Big5.po Wed Jul 3 07:58:09 2002
+@@ -1887,11 +1887,11 @@
+
+ #: ../../WPrefs.app/WindowHandling.c:366
+ msgid "...do not cover icons"
+-msgstr "...¤£­nÂл\\¹Ï¥Ü"
++msgstr "...¤£­nÂл\¹Ï¥Ü"
+
+ #: ../../WPrefs.app/WindowHandling.c:372
+ msgid "...do not cover dock"
+-msgstr "...¤£­nÂл\\°±¾a°Ï"
++msgstr "...¤£­nÂл\°±¾a°Ï"
+
+ #: ../../WPrefs.app/WindowHandling.c:381
+ msgid "Edge Resistance"
+@@ -2063,3 +2063,4 @@
+ #: ../../WPrefs.app/main.c:161
+ msgid "could not initialize application"
+ msgstr "µLªk±Ò©lÀ³¥Îµ{¦¡"
++
+diff -urN WindowMaker-0.80.1.old/po/zh_TW.Big5.po WindowMaker-0.80.1/po/zh_TW.Big5.po
+--- WindowMaker-0.80.1.old/po/zh_TW.Big5.po Tue Jan 8 05:45:06 2002
++++ WindowMaker-0.80.1/po/zh_TW.Big5.po Wed Jul 3 07:58:04 2002
+@@ -519,8 +519,8 @@
+ "is docked in the same positions on the other workspaces and the Clip is not "
+ "full in some workspace."
+ msgstr ""
+-"¬Y¨Ç¹Ï¥ÜµLªk³]¦¨µL©Ò¤£¦b¡C½Ð½T»{¦b¨ä¥L¤u§@°Ï¦P¤@­Ó¦ì¸m¤W¨S¦³¨ä¥L¹Ï¥Ü°±¾a¥B¦b¬"
+-"Y¨Ç¤u§@°Ïªº°j¯¾°w¥¼º¡¡C"
++"¬Y¨Ç¹Ï¥ÜµLªk³]¦¨µL©Ò¤£¦b¡C "
++"½Ð½T»{¦b¨ä¥L¤u§@°Ï¦P¤@­Ó¦ì¸m¤W¨S¦³¨ä¥L¹Ï¥Ü°±¾a¥B¦b¬Y¨Ç¤u§@°Ïªº°j¯¾°w¥¼º¡¡C"
+
+ #: ../src/dock.c:529
+ msgid ""
+@@ -528,8 +528,8 @@
+ "docked in the same position on the other workspaces and the Clip is not full "
+ "in some workspace."
+ msgstr ""
+-"¹Ï¥ÜµLªk³]¦¨µL©Ò¤£¦b¡C½Ð½T»{¦b¨ä¥L¤u§@°Ï¦P¤@­Ó¦ì¸m¤W¨S¦³¨ä¥L¹Ï¥Ü°±¾a¥B¦b¬Y¨Ç¤"
+-"u§@°Ïªº°j¯¾°w¥¼º¡¡C"
++"¹Ï¥ÜµLªk³]¦¨µL©Ò¤£¦b¡C "
++"½Ð½T»{¦b¨ä¥L¤u§@°Ï¦P¤@­Ó¦ì¸m¤W¨S¦³¨ä¥L¹Ï¥Ü°±¾a¥B¦b¬Y¨Ç¤u§@°Ïªº°j¯¾°w¥¼º¡¡C"
+
+ #: ../src/dock.c:556
+ msgid "Workspace Clip"
+@@ -1142,13 +1142,13 @@
+ msgid ""
+ "There are more than one WORKSPACE_MENU commands in the applications menu. "
+ "Only one is allowed."
+-msgstr "À³¥Îµ{¦¡¿ï³æ¤¤¦³¶W¹L¤@­Ó WORKSPACE_MENU ©R¥O¡C¥u¤¹³\\¤@­Ó¡C"
++msgstr "À³¥Îµ{¦¡¿ï³æ¤¤¦³¶W¹L¤@­Ó WORKSPACE_MENU ©R¥O¡C¥u¤¹³\¤@­Ó¡C"
+
+ #: ../src/rootmenu.c:834
+ msgid ""
+ "There are more than one WINDOWS_MENU commands in the applications menu. Only "
+ "one is allowed."
+-msgstr "À³¥Îµ{¦¡¿ï³æ¤¤¦³¶W¹L¤@­Ó WINDOWS_MENU ©R¥O¡C¥u¤¹³\\¤@­Ó¡C"
++msgstr "À³¥Îµ{¦¡¿ï³æ¤¤¦³¶W¹L¤@­Ó WINDOWS_MENU ©R¥O¡C¥u¤¹³\¤@­Ó¡C"
+
+ #: ../src/rootmenu.c:839
+ msgid "Window List"
+@@ -1502,11 +1502,11 @@
+ #: ../src/winspector.c:1121
+ #, c-format
+ msgid "Inspecting %s.%s"
+-msgstr "À˾\\ %s.%s"
++msgstr "À˾\ %s.%s"
+
+ #: ../src/winspector.c:1147
+ msgid "Click in the window you wish to inspect."
+-msgstr "¦b§A·QÀ˾\\ªºµøµ¡ÂI¤@¤U"
++msgstr "¦b§A·QÀ˾\ªºµøµ¡ÂI¤@¤U"
+
+ #: ../src/winspector.c:1186
+ msgid ""
+@@ -1620,7 +1620,7 @@
+ msgid ""
+ "Keep the window over other windows, not allowing\n"
+ "them to cover it."
+-msgstr "Åýµøµ¡«O«ù¦b¨ä¥Lµøµ¡¤§¤W¡A¤£³\\¥¦­ÌÂл\\¥¦¡C"
++msgstr "Åýµøµ¡«O«ù¦b¨ä¥Lµøµ¡¤§¤W¡A¤£³\¥¦­ÌÂл\¥¦¡C"
+
+ #: ../src/winspector.c:1370
+ msgid "Keep at bottom (sunken)"
+@@ -1682,7 +1682,7 @@
+ "of your shortcut configuration."
+ msgstr ""
+ "·í¦¹µøµ¡±o¨ìµJÂI®É¤£­n±q Window Maker µ²¦XÁä½L±¶®|¡C\n"
+-"³o¤¹³\\µøµ¡±o¨ì©Ò¦³Áä½L²Õ¦X¤£²z·|§Aªº±¶®|³]©w¡C"
++"³o¤¹³\µøµ¡±o¨ì©Ò¦³Áä½L²Õ¦X¤£²z·|§Aªº±¶®|³]©w¡C"
+
+ #: ../src/winspector.c:1436
+ msgid "Do not bind mouse clicks"
+@@ -1720,7 +1720,7 @@
+ msgid ""
+ "Do not allow the window to move itself completely\n"
+ "outside the screen. For bug compatibility.\n"
+-msgstr "¤£¤¹³\\µøµ¡§¹¥þ²¾¥X¿Ã¹õ¡C¥Î©ó¿ù»~¬Û®e©Ê¡C\n"
++msgstr "¤£¤¹³\µøµ¡§¹¥þ²¾¥X¿Ã¹õ¡C¥Î©ó¿ù»~¬Û®e©Ê¡C\n"
+
+ #: ../src/winspector.c:1460
+ msgid "Ignore 'Hide Others'"
+@@ -1848,3 +1848,4 @@
+ #: ../src/workspace.c:936
+ msgid "Destroy Last"
+ msgstr "§R°£³Ì«áªº¤u§@°Ï"
++
diff --git a/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r1 b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r1
new file mode 100644
index 000000000000..c05f660bc310
--- /dev/null
+++ b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1-r1
@@ -0,0 +1,2 @@
+MD5 b1c88c8ecb8f4484d0ae953b9a730418 WindowMaker-0.80.1.tar.gz 2503965
+MD5 07c7700daaaf232bc490f5abaabef085 WindowMaker-extra-0.1.tar.gz 238018