summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-02 11:44:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-02 11:44:47 +0000
commit85e68bcd9597d0b0139b397fcad1e99a951e60cd (patch)
treeb002ba1fe653137d12f554af8503451d45098af8 /x11-wm/WindowMaker
parentsmall fix0r (diff)
downloadgentoo-2-85e68bcd9597d0b0139b397fcad1e99a951e60cd.tar.gz
gentoo-2-85e68bcd9597d0b0139b397fcad1e99a951e60cd.tar.bz2
gentoo-2-85e68bcd9597d0b0139b397fcad1e99a951e60cd.zip
version bump
Diffstat (limited to 'x11-wm/WindowMaker')
-rw-r--r--x11-wm/WindowMaker/ChangeLog9
-rw-r--r--x11-wm/WindowMaker/WindowMaker-0.80.1.ebuild122
-rw-r--r--x11-wm/WindowMaker/files/digest-WindowMaker-0.80.12
3 files changed, 132 insertions, 1 deletions
diff --git a/x11-wm/WindowMaker/ChangeLog b/x11-wm/WindowMaker/ChangeLog
index 5a2ab9615657..91798e983a89 100644
--- a/x11-wm/WindowMaker/ChangeLog
+++ b/x11-wm/WindowMaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/WindowMaker
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/ChangeLog,v 1.7 2002/05/10 14:27:13 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/ChangeLog,v 1.8 2002/07/02 11:44:47 seemant Exp $
+
+*WindowMaker-0.80.1 (02 Jul 2002)
+
+ 02 Jul 2002; Seemant Kulleen <seemant@gentoo.org> WindowMaker-0.80.1.ebuild
+ files/digest-WindowMaker-0.80.1 :
+
+ Version bump.
*WindowMaker-0.80.0-r3 (10 May 2002)
10 May 2002; José Alberto Suárez López <bass@gentoo.org> WindowMaker-0.80.0-r3.ebuild :
diff --git a/x11-wm/WindowMaker/WindowMaker-0.80.1.ebuild b/x11-wm/WindowMaker/WindowMaker-0.80.1.ebuild
new file mode 100644
index 000000000000..92e427393680
--- /dev/null
+++ b/x11-wm/WindowMaker/WindowMaker-0.80.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/WindowMaker/WindowMaker-0.80.1.ebuild,v 1.1 2002/07/02 11:44:47 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window Maker"
+SRC_URI="ftp://ftp.windowmaker.org/pub/source/release/${P}.tar.gz
+ ftp://ftp.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
+HOMEPAGE="http://www.windowmaker.org/"
+
+DEPEND="virtual/x11
+ >=media-libs/tiff-3.5.5
+ x11-wm/gnustep-env
+ gif? ( >=media-libs/giflib-4.1.0-r3
+ >=media-libs/libungif-4.1.0 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )"
+
+RDEPEND="nls? ( >=sys-devel/gettext-0.10.39 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+
+#NOTE: the default menu has the wrong path for the WMPrefs utility.
+# Needs fixing.
+
+src_compile() {
+
+ patch -p1 < ${FILESDIR}/wmfpo-80.patch
+
+ local myconf
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ && export KDEDIR=/usr/kde/2 \
+ || myconf="${myconf} --disable-kde"
+
+ if [ "$WITH_MODELOCK" ] ; then
+ myconf="${myconf} --enable-modelock"
+ else
+ myconf="${myconf} --disable-modelock"
+ fi
+
+ use nls \
+ && export LINGUAS="`ls po/*.po | sed 's:po/\(.*\)\.po$:\1:'`" \
+ || myconf="${myconf} --disable-nls --disable-locale"
+
+ use gif \
+ || myconf="${myconf} --disable-gif"
+
+ use jpeg \
+ || myconf="${myconf} --disable-jpeg"
+
+ use png \
+ || myconf="${myconf} --disable-png"
+
+
+ use esd || use alsa || use oss \
+ && myconf="${myconf} --enable-sound" \
+ || myconf="${myconf} --disable-sound"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc/X11 \
+ --with-x \
+ --enable-newstyle \
+ --enable-superfluous \
+ --enable-usermenu \
+ ${myconf} || die
+
+ emake || die
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+
+ make || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/X11 \
+ GNUSTEP_LOCAL_ROOT=${D}${GNUSTEP_LOCAL_ROOT} \
+ install || die
+
+ cp -f WindowMaker/plmenu ${D}/etc/X11/WindowMaker/WMRootMenu
+
+ dodoc AUTHORS BUGFORUM BUGS ChangeLog COPYING* INSTALL* FAQ* \
+ MIRRORS README* NEWS TODO
+
+ # WindowMaker Extra
+ cd ../WindowMaker-extra-0.1
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ newdoc README README.extra
+}
+
+pkg_postinst() {
+
+ echo
+ echo '######################################################################'
+ echo '# If do you want trans globes and other trans elements do you need #'
+ echo '# the libxpm (media-libs/xpm). #'
+ echo '######################################################################'
+ }
+
diff --git a/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1 b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1
new file mode 100644
index 000000000000..c05f660bc310
--- /dev/null
+++ b/x11-wm/WindowMaker/files/digest-WindowMaker-0.80.1
@@ -0,0 +1,2 @@
+MD5 b1c88c8ecb8f4484d0ae953b9a730418 WindowMaker-0.80.1.tar.gz 2503965
+MD5 07c7700daaaf232bc490f5abaabef085 WindowMaker-extra-0.1.tar.gz 238018