summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-01-21 15:59:41 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-01-21 15:59:41 +0000
commit7daf8cf5227c1822ff0ec9fc4cf991167cd3f476 (patch)
tree4bddaeec0582eb4bc235e3ccb1ff9271b745e9a2 /x11-wm/awesome/awesome-2.1.ebuild
parentStable for HPPA (bug #206706). (diff)
downloadgentoo-2-7daf8cf5227c1822ff0ec9fc4cf991167cd3f476.tar.gz
gentoo-2-7daf8cf5227c1822ff0ec9fc4cf991167cd3f476.tar.bz2
gentoo-2-7daf8cf5227c1822ff0ec9fc4cf991167cd3f476.zip
Version bumped.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-wm/awesome/awesome-2.1.ebuild')
-rw-r--r--x11-wm/awesome/awesome-2.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-wm/awesome/awesome-2.1.ebuild b/x11-wm/awesome/awesome-2.1.ebuild
new file mode 100644
index 000000000000..759efc798ef5
--- /dev/null
+++ b/x11-wm/awesome/awesome-2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/awesome/awesome-2.1.ebuild,v 1.1 2008/01/21 15:59:40 matsuu Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="awesome is a window manager initialy based on a dwm code rewriting"
+HOMEPAGE="http://awesome.naquadah.org/"
+SRC_URI="http://awesome.naquadah.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/confuse-2.6
+ x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+
+DEPEND="${RDEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ app-doc/doxygen
+ dev-util/pkgconfig
+ x11-proto/xineramaproto"
+
+src_compile() {
+ econf --docdir="/usr/share/doc/${PF}" || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+
+ insinto /usr/share/awesome/icons/layouts
+ doins icons/layouts/*
+
+ prepalldocs
+}