summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 05:45:49 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-04-03 05:45:49 +0000
commit8291c76427279be903c748b85a3072d739f81142 (patch)
treeba818d7bd79be6ea001fbbee9443642e87516b11 /x11-wm/emerald
parentReplaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release a... (diff)
downloadgentoo-2-8291c76427279be903c748b85a3072d739f81142.tar.gz
gentoo-2-8291c76427279be903c748b85a3072d739f81142.tar.bz2
gentoo-2-8291c76427279be903c748b85a3072d739f81142.zip
Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6 release and to avoid future dep issues.
Did a revbump to avoid issues with installed packages. Added a patch to enable emerald to build with gtk+-2.20. Fixes bug 308791 - thanks to Leif Walsh <adlaiff6@gmail.com>. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/emerald')
-rw-r--r--x11-wm/emerald/ChangeLog14
-rw-r--r--x11-wm/emerald/emerald-0.8.4-r1.ebuild42
-rw-r--r--x11-wm/emerald/files/emerald-0.8.4-gtk+-2.20-build.patch33
3 files changed, 87 insertions, 2 deletions
diff --git a/x11-wm/emerald/ChangeLog b/x11-wm/emerald/ChangeLog
index 634ededfbb60..34db43454387 100644
--- a/x11-wm/emerald/ChangeLog
+++ b/x11-wm/emerald/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-wm/emerald
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/emerald/ChangeLog,v 1.29 2009/12/20 15:48:25 mrpouet Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/emerald/ChangeLog,v 1.30 2010/04/03 05:45:49 jmbsvicetto Exp $
+
+*emerald-0.8.4-r1 (03 Apr 2010)
+
+ 03 Apr 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +emerald-0.8.4-r1.ebuild, +files/emerald-0.8.4-gtk+-2.20-build.patch:
+ Replaced compiz ~ deps with >= deps to support the new compiz-0.8.6
+ release and to avoid future dep issues.
+ Did a revbump to avoid issues with installed packages.
+ Added a patch to enable emerald to build with gtk+-2.20. Fixes bug 308791
+ - thanks to Leif Walsh <adlaiff6@gmail.com>.
20 Dec 2009; Romain Perier <mrpouet@gentoo.org> -emerald-0.5.2.ebuild,
-emerald-0.8.2.ebuild, -files/emerald-ru.po.patch:
diff --git a/x11-wm/emerald/emerald-0.8.4-r1.ebuild b/x11-wm/emerald/emerald-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..2e67636f8421
--- /dev/null
+++ b/x11-wm/emerald/emerald-0.8.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/emerald/emerald-0.8.4-r1.ebuild,v 1.1 2010/04/03 05:45:49 jmbsvicetto Exp $
+
+EAPI="2"
+
+inherit eutils
+
+THEMES_RELEASE=0.5.2
+
+DESCRIPTION="Emerald Window Decorator"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+PDEPEND="~x11-themes/emerald-themes-${THEMES_RELEASE}"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.8.0
+ >=x11-libs/libwnck-2.14.2
+ >=x11-wm/compiz-${PV}
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ >=sys-devel/gettext-0.15
+"
+
+PATCHES=( "${FILESDIR}-${P}-gtk+-2.20-build.patch" )
+
+src_configure() {
+ econf --disable-mime-update || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/x11-wm/emerald/files/emerald-0.8.4-gtk+-2.20-build.patch b/x11-wm/emerald/files/emerald-0.8.4-gtk+-2.20-build.patch
new file mode 100644
index 000000000000..3dc7bf4488ad
--- /dev/null
+++ b/x11-wm/emerald/files/emerald-0.8.4-gtk+-2.20-build.patch
@@ -0,0 +1,33 @@
+diff -urN emerald-0.8.4/libengine/themer.c emerald-0.8.4.new/libengine/themer.c
+--- emerald-0.8.4/libengine/themer.c 2009-10-13 20:56:23.000000000 -0400
++++ emerald-0.8.4.new/libengine/themer.c 2010-03-10 01:20:03.046827674 -0500
+@@ -461,7 +461,7 @@
+ }
+ gdouble get_float(SettingItem * item)
+ {
+- if(!strcmp(GTK_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
++ if(!strcmp(G_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
+ return gtk_spin_button_get_value((GtkSpinButton *)item->widget);
+ }
+ else {
+@@ -647,7 +647,7 @@
+ }
+ void set_float(SettingItem * item, gdouble f)
+ {
+- if(!strcmp(GTK_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
++ if(!strcmp(G_OBJECT_TYPE_NAME(item->widget),"GtkSpinButton")) {
+ gtk_spin_button_set_value((GtkSpinButton *)item->widget, f);
+ }
+ else {
+--- emerald-0.8.4/src/main.c.old 2010-03-29 19:49:30.420710030 -0700
++++ emerald-0.8.4/src/main.c 2010-03-29 19:52:33.654024944 -0700
+@@ -3757,7 +3757,7 @@
+
+ static void hide_tooltip(void)
+ {
+- if (GTK_WIDGET_VISIBLE(tip_window))
++ if (gtk_widget_get_visible(tip_window))
+ g_get_current_time(&tooltip_last_popdown);
+
+ gtk_widget_hide(tip_window);
+