summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-09 05:45:47 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-09 05:45:47 +0000
commit4d60bb7900b617fef678f9f84dec9ecce7c8f763 (patch)
tree67d60dcb949357b581ab6a03889f0326735096f5 /x11-wm/ion
parentnew icewm to close bug #610 (diff)
downloadgentoo-2-4d60bb7900b617fef678f9f84dec9ecce7c8f763.tar.gz
gentoo-2-4d60bb7900b617fef678f9f84dec9ecce7c8f763.tar.bz2
gentoo-2-4d60bb7900b617fef678f9f84dec9ecce7c8f763.zip
New ion ebuild, closing bug #611
Diffstat (limited to 'x11-wm/ion')
-rw-r--r--x11-wm/ion/ChangeLog7
-rw-r--r--x11-wm/ion/files/digest-ion-200202071
-rw-r--r--x11-wm/ion/ion-20020207.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/x11-wm/ion/ChangeLog b/x11-wm/ion/ChangeLog
index bcb992870742..ffe25c57434f 100644
--- a/x11-wm/ion/ChangeLog
+++ b/x11-wm/ion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/ion
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ChangeLog,v 1.1 2002/02/01 21:53:39 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ChangeLog,v 1.2 2002/02/09 05:45:47 drobbins Exp $
+
+*ion-20020207 (8 Feb 2002)
+
+ 8 Feb 2002; Daniel Robbins <drobbins@gentoo.org> Added a new ion ebuild from
+ Doug Miller.
*ion-20011109-r1 (1 Feb 2002)
diff --git a/x11-wm/ion/files/digest-ion-20020207 b/x11-wm/ion/files/digest-ion-20020207
new file mode 100644
index 000000000000..2c51c5253f43
--- /dev/null
+++ b/x11-wm/ion/files/digest-ion-20020207
@@ -0,0 +1 @@
+MD5 2e909abb45efefb08b1ceb886bf34cfe ion-20020207.tar.gz 157649
diff --git a/x11-wm/ion/ion-20020207.ebuild b/x11-wm/ion/ion-20020207.ebuild
new file mode 100644
index 000000000000..9d0d64811e3d
--- /dev/null
+++ b/x11-wm/ion/ion-20020207.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Doug Miller <orkim@kc.rr.com>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A keyboard-based window manager"
+SRC_URI="http://www.students.tut.fi/~tuomov/dl/${P}.tar.gz"
+HOMEPAGE="http://www.students.tut.fi/~tuomov/ion/"
+DEPEND="virtual/glibc"
+RDEPEND="virtual/x11"
+
+src_compile() {
+ cd ${S}
+
+ # Edit system.mk
+ cp system.mk system.mk.new
+ sed -e 's:PREFIX=/usr/local:PREFIX=/usr:' \
+ -e 's:ETCDIR=$(PREFIX)/etc:ETCDIR=/etc/X11:' \
+ -e 's:$(PREFIX)/man:$(PREFIX)/share/man:' \
+ -e 's:$(PREFIX)/doc:$(PREFIX)/share/doc:' \
+ -e 's:#HAS_SYSTEM_ASPRINTF=1:HAS_SYSTEM_ASPRINTF=1:' \
+ -e 's:#INSTALL=install -c:INSTALL=install -c:' \
+ -e 's:INSTALL=install *$:#INSTALL=install:' \
+ system.mk.new > system.mk
+
+ cp Makefile Makefile.new
+ sed -e 's:$(DOCDIR)/ion:$(DOCDIR)/${P}:g' Makefile.new > Makefile
+
+ make depend || die
+ emake || die
+}
+
+src_install () {
+ make PREFIX=${D}/usr ETCDIR=${D}/etc/X11 install || die
+}
+
+pkg_postinst () {
+ einfo "Configuration documentation can be found in these places:"
+ einfo "/usr/share/doc/${P}/config.txt"
+ einfo "http://www.students.tut.fi/~tuomov/ion/resources.html"
+}