summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-31 02:39:40 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-31 02:39:40 +0000
commit38170a88c20753e45457e3fc0afe870cd0238c00 (patch)
tree030898ed5971d8120254ef6ae6d1196978c5f801 /x11-wm/metacity
parentGNOME 2.2 RC2 commit (diff)
downloadgentoo-2-38170a88c20753e45457e3fc0afe870cd0238c00.tar.gz
gentoo-2-38170a88c20753e45457e3fc0afe870cd0238c00.tar.bz2
gentoo-2-38170a88c20753e45457e3fc0afe870cd0238c00.zip
GNOME 2.2 RC2
Diffstat (limited to 'x11-wm/metacity')
-rw-r--r--x11-wm/metacity/metacity-2.4.21.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-wm/metacity/metacity-2.4.21.ebuild b/x11-wm/metacity/metacity-2.4.21.ebuild
new file mode 100644
index 000000000000..720e1d117386
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.4.21.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.4.21.ebuild,v 1.1 2003/01/31 02:39:40 foser Exp $
+
+inherit gnome2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Small gtk2 WindowManager"
+HOMEPAGE="http://people.redhat.com/~hp/metacity/"
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="virtual/x11
+ >=x11-libs/gtk+-2
+ >=gnome-base/gconf-1.2
+ >=gnome-base/libglade-2
+ >=x11-libs/startup-notification-0.4"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.21"
+
+DOCS="AUTHORS ChangeLog HACKING INSTALL NEWS README"
+
+src_unpack(){
+ unpack ${A}
+ # causes ICE on ppc w/ gcc (still)
+ cd ${S}
+ use ppc && (
+ [ -z "${CC}" ] && CC=gcc
+ if [ "`${CC} -dumpversion | cut -d. -f1,2`" != "2.95" ] ; then
+ patch -p0 < ${FILESDIR}/metacity-2.4.3-ppc-gcc3.2.diff || die "patch failed"
+ fi
+ )
+}