summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-04 20:33:03 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-02-04 20:33:03 +0000
commit2d19be5e7176c32f0894a3dbb88e99b76ff15325 (patch)
tree908aa472ee1cd79cab1cba9fcb72fb377ade8a09 /x11-wm/mutter
parentold (diff)
downloadgentoo-2-2d19be5e7176c32f0894a3dbb88e99b76ff15325.tar.gz
gentoo-2-2d19be5e7176c32f0894a3dbb88e99b76ff15325.tar.bz2
gentoo-2-2d19be5e7176c32f0894a3dbb88e99b76ff15325.zip
Fix building with USE=-introspection (bug #402113, thanks to Anthony Parsons).
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/mutter')
-rw-r--r--x11-wm/mutter/ChangeLog7
-rw-r--r--x11-wm/mutter/files/mutter-3.2.2-disable-introspection.patch27
-rw-r--r--x11-wm/mutter/mutter-3.2.2.ebuild5
3 files changed, 37 insertions, 2 deletions
diff --git a/x11-wm/mutter/ChangeLog b/x11-wm/mutter/ChangeLog
index e314dec919be..58bd762a7561 100644
--- a/x11-wm/mutter/ChangeLog
+++ b/x11-wm/mutter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/mutter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/ChangeLog,v 1.5 2012/01/21 02:06:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/ChangeLog,v 1.6 2012/02/04 20:33:03 tetromino Exp $
+
+ 04 Feb 2012; Alexandre Rostovtsev <tetromino@gentoo.org> mutter-3.2.2.ebuild,
+ +files/mutter-3.2.2-disable-introspection.patch:
+ Fix building with USE=-introspection (bug #402113, thanks to Anthony
+ Parsons).
*mutter-3.2.2 (21 Jan 2012)
diff --git a/x11-wm/mutter/files/mutter-3.2.2-disable-introspection.patch b/x11-wm/mutter/files/mutter-3.2.2-disable-introspection.patch
new file mode 100644
index 000000000000..454376aff193
--- /dev/null
+++ b/x11-wm/mutter/files/mutter-3.2.2-disable-introspection.patch
@@ -0,0 +1,27 @@
+From 41ae760454fa6b4aff50ff417d8a6ea265d82253 Mon Sep 17 00:00:00 2001
+From: Lionel Landwerlin <llandwerlin@gmail.com>
+Date: Fri, 25 Nov 2011 18:28:38 +0000
+Subject: Fix compilation with --disable-introspection
+
+Signed-off-by: Lionel Landwerlin <lionel.g.landwerlin@linux.intel.com>
+
+https://bugzilla.gnome.org/show_bug.cgi?id=661871
+---
+(limited to 'src/core/mutter.c')
+
+diff --git a/src/core/mutter.c b/src/core/mutter.c
+index 159bbf3..117a549 100644
+--- a/src/core/mutter.c
++++ b/src/core/mutter.c
+@@ -25,9 +25,7 @@
+
+ #include <meta/main.h>
+ #include <meta/util.h>
+-#ifdef HAVE_INTROSPECTION
+ #include "meta-plugin-manager.h"
+-#endif
+
+ #include <glib.h>
+
+--
+cgit v0.9.0.2
diff --git a/x11-wm/mutter/mutter-3.2.2.ebuild b/x11-wm/mutter/mutter-3.2.2.ebuild
index 2fb7d16a899c..d6a1d00d50eb 100644
--- a/x11-wm/mutter/mutter-3.2.2.ebuild
+++ b/x11-wm/mutter/mutter-3.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/mutter-3.2.2.ebuild,v 1.1 2012/01/21 02:06:12 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/mutter-3.2.2.ebuild,v 1.2 2012/02/04 20:33:03 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -74,5 +74,8 @@ src_prepare() {
# Compat with Ubuntu metacity themes (e.g. x11-themes/light-themes)
epatch "${FILESDIR}/${PN}-3.2.1-ignore-shadow-and-padding.patch"
+ # Patch from 3.3.x, fixes building without introspection
+ epatch "${FILESDIR}/${P}-disable-introspection.patch"
+
gnome2_src_prepare
}