summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-05 07:51:29 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-05 07:51:29 +0000
commitc155a3f0700b6ab1ffaca2a3915f921fe47554e9 (patch)
tree031054c55351892687fb9def50e8667265b71b7b /x11-wm/mutter
parentdoesn't work with Python 3, restrict dependency (diff)
downloadgentoo-2-c155a3f0700b6ab1ffaca2a3915f921fe47554e9.tar.gz
gentoo-2-c155a3f0700b6ab1ffaca2a3915f921fe47554e9.tar.bz2
gentoo-2-c155a3f0700b6ab1ffaca2a3915f921fe47554e9.zip
Bump to 3.2.1 from the gnome overlay. Notable changes: better performance, improved handling for transparent windows, visual improvements.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/mutter')
-rw-r--r--x11-wm/mutter/ChangeLog9
-rw-r--r--x11-wm/mutter/mutter-3.2.1.ebuild71
2 files changed, 79 insertions, 1 deletions
diff --git a/x11-wm/mutter/ChangeLog b/x11-wm/mutter/ChangeLog
index d7dae42d3998..a7a0f0b1a4b6 100644
--- a/x11-wm/mutter/ChangeLog
+++ b/x11-wm/mutter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/mutter
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/ChangeLog,v 1.1 2011/09/30 16:35:42 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/ChangeLog,v 1.2 2011/11/05 07:51:29 tetromino Exp $
+
+*mutter-3.2.1 (05 Nov 2011)
+
+ 05 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +mutter-3.2.1.ebuild:
+ Bump to 3.2.1 from the gnome overlay. Notable changes: better performance,
+ improved handling for transparent windows, visual improvements.
*mutter-3.0.2.1 (30 Sep 2011)
diff --git a/x11-wm/mutter/mutter-3.2.1.ebuild b/x11-wm/mutter/mutter-3.2.1.ebuild
new file mode 100644
index 000000000000..fd7959f10ee4
--- /dev/null
+++ b/x11-wm/mutter/mutter-3.2.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/mutter/mutter-3.2.1.ebuild,v 1.1 2011/11/05 07:51:29 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="http://git.gnome.org/browse/mutter/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+ >=gnome-base/gconf-2:2
+ >=dev-libs/glib-2.14:2
+ >=media-libs/clutter-1.7.5:1.0
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README *.txt doc/*.txt"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ --with-libcanberra
+ $(use_enable introspection)
+ $(use_enable xinerama)"
+}