summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-04-30 12:51:05 +0000
committerJeroen Roovers <jer@gentoo.org>2009-04-30 12:51:05 +0000
commit763ce40c0e990c84e6201a51757c4604e9ab533a (patch)
tree41f31ff527b1ae86ae030d01a0566a5634dd2deb /x11-wm/ratpoison
parentRemove old. (diff)
downloadgentoo-2-763ce40c0e990c84e6201a51757c4604e9ab533a.tar.gz
gentoo-2-763ce40c0e990c84e6201a51757c4604e9ab533a.tar.bz2
gentoo-2-763ce40c0e990c84e6201a51757c4604e9ab533a.zip
Version bump. Make building libhistory support a default option.
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'x11-wm/ratpoison')
-rw-r--r--x11-wm/ratpoison/ChangeLog7
-rw-r--r--x11-wm/ratpoison/metadata.xml4
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.4.ebuild70
3 files changed, 79 insertions, 2 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index d2359da91285..e464d6318c35 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/ratpoison
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.64 2008/11/30 18:34:37 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.65 2009/04/30 12:51:05 jer Exp $
+
+ 30 Apr 2009; Jeroen Roovers <jer@gentoo.org> metadata.xml:
+ Version bump. Make building libhistory support a default option.
30 Nov 2008; Raúl Porcel <armin76@gentoo.org> ratpoison-1.4.3.ebuild:
sparc stable wrt #247131
diff --git a/x11-wm/ratpoison/metadata.xml b/x11-wm/ratpoison/metadata.xml
index c5e161dc5a99..2f484cbcfd5e 100644
--- a/x11-wm/ratpoison/metadata.xml
+++ b/x11-wm/ratpoison/metadata.xml
@@ -15,4 +15,8 @@
ratpoison has a prefix map to minimize the key clobbering that cripples
Emacs and other quality pieces of software.
</longdescription>
+<use>
+ <flag name="history">Save ratpoison command history using
+ <pkg>sys-libs/readline</pkg></flag>
+</use>
</pkgmetadata>
diff --git a/x11-wm/ratpoison/ratpoison-1.4.4.ebuild b/x11-wm/ratpoison/ratpoison-1.4.4.ebuild
new file mode 100644
index 000000000000..eea439234286
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.4.ebuild,v 1.1 2009/04/30 12:51:05 jer Exp $
+
+EAPI="2"
+
+inherit elisp-common eutils autotools
+
+DESCRIPTION="Ratpoison is an extremely light-weight and barebones wm modelled after screen"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs +history"
+
+DEPEND="x11-libs/libXinerama
+ x11-libs/libXtst
+ virtual/perl-PodParser
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
+
+SITEFILE=50ratpoison-gentoo.el
+
+src_prepare() {
+ cd "${S}/contrib"
+ epatch "${FILESDIR}/ratpoison.el-gentoo.patch"
+
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+ use history || myconf="--disable-history"
+ econf ${myconf} || die "econf failed"
+ emake CFLAGS="${CFLAGS} -I/usr/X11R6/include" || die "emake failed"
+ if use emacs; then
+ elisp-compile contrib/ratpoison.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ einstall
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}/ratpoison.xsession" ratpoison
+
+ dodoc INSTALL TODO README NEWS AUTHORS ChangeLog
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${D}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}