summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-08-15 11:50:37 +0000
committerMichael Weber <xmw@gentoo.org>2013-08-15 11:50:37 +0000
commit7b2de4d04c5e6857b557122fd64d4b17e79c8ff5 (patch)
tree5205df14dc99ecd7f03c0d70a18059f75526fc9c /x11-wm/xpra
parentFix thumbnailing failure with glib-2.34 (bug #450930, thanks to Matthew Turnb... (diff)
downloadgentoo-2-7b2de4d04c5e6857b557122fd64d4b17e79c8ff5.tar.gz
gentoo-2-7b2de4d04c5e6857b557122fd64d4b17e79c8ff5.tar.bz2
gentoo-2-7b2de4d04c5e6857b557122fd64d4b17e79c8ff5.zip
Version bump, drop old version
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'x11-wm/xpra')
-rw-r--r--x11-wm/xpra/ChangeLog8
-rw-r--r--x11-wm/xpra/metadata.xml1
-rw-r--r--x11-wm/xpra/xpra-0.10.0.ebuild (renamed from x11-wm/xpra/xpra-0.9.6.ebuild)29
-rw-r--r--x11-wm/xpra/xpra-0.9.5-r2.ebuild101
-rw-r--r--x11-wm/xpra/xpra-0.9.7.ebuild100
5 files changed, 22 insertions, 217 deletions
diff --git a/x11-wm/xpra/ChangeLog b/x11-wm/xpra/ChangeLog
index 7942617f6837..8d25c9633ced 100644
--- a/x11-wm/xpra/ChangeLog
+++ b/x11-wm/xpra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/xpra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/ChangeLog,v 1.76 2013/08/11 23:02:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/ChangeLog,v 1.77 2013/08/15 11:50:37 xmw Exp $
+
+*xpra-0.10.0 (15 Aug 2013)
+
+ 15 Aug 2013; Michael Weber <xmw@gentoo.org> +xpra-0.10.0.ebuild,
+ -xpra-0.9.5-r2.ebuild, -xpra-0.9.6.ebuild, -xpra-0.9.7.ebuild, metadata.xml:
+ Version bump, drop old version
11 Aug 2013; Alexis Ballier <aballier@gentoo.org> xpra-0.8.8.ebuild,
xpra-0.9.5-r2.ebuild, xpra-0.9.6.ebuild, xpra-0.9.7.ebuild,
diff --git a/x11-wm/xpra/metadata.xml b/x11-wm/xpra/metadata.xml
index 0bc38d6eca76..5581337a7bae 100644
--- a/x11-wm/xpra/metadata.xml
+++ b/x11-wm/xpra/metadata.xml
@@ -9,6 +9,7 @@
<bugs-to>https://www.xpra.org/trac/report</bugs-to>
</upstream>
<use>
+ <flag name='client'>Build client-side code</flag>
<flag name='server'>Build server-side code</flag>
<flag name='clipboard'>Enable clipboard support</flag>
<flag name='rencode'>Enable rencode support</flag>
diff --git a/x11-wm/xpra/xpra-0.9.6.ebuild b/x11-wm/xpra/xpra-0.10.0.ebuild
index 8b766b0548c6..006eeb80c082 100644
--- a/x11-wm/xpra/xpra-0.9.6.ebuild
+++ b/x11-wm/xpra/xpra-0.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/xpra-0.9.6.ebuild,v 1.2 2013/08/11 23:02:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/xpra-0.10.0.ebuild,v 1.1 2013/08/15 11:50:37 xmw Exp $
EAPI=5
@@ -14,7 +14,7 @@ SRC_URI="http://xpra.org/src/${P}.tar.bz2"
LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+clipboard opengl pulseaudio +rencode server sound vpx webp x264"
+IUSE="+client +clipboard gtk opengl pulseaudio qt4 +rencode server sound vpx webp x264"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -59,8 +59,7 @@ DEPEND="${COMMON_DEPEND}
python_prepare_all() {
epatch \
"${FILESDIR}"/${PN}-0.7.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.8.0-prefix.patch \
- "${FILESDIR}"/${PN}-0.9.5-opengl-auto.patch
+ "${FILESDIR}"/${PN}-0.8.0-prefix.patch
#assuming ffmpeg and libav mutual exclusive installs
if has_version "media-video/libav" ; then
@@ -72,29 +71,29 @@ python_prepare_all() {
python_configure_all() {
mydistutilsargs=(
+ $(use_with client)
$(use_with clipboard)
+ $(use_with gtk gtk2)
$(use_with opengl)
+ $(use_with qt4)
$(use_with rencode)
$(use_with server)
$(use_with sound)
$(use_with vpx)
$(use_with webp)
- $(use_with x264)
+ $(use_with x264 enc_x264)
+ --with-Xdummy
+ --with-argb
+ --with-csc_swscale
+ --without-csc_nvcuda
--with-cymaths
--with-cyxor
- --with-parti
+ --with-dec_avcodec
+ --with-nvenc
--with-shadow
--with-strict
--with-warn
+ --with-x11
--without-PIC
--without-debug )
}
-
-src_install() {
- distutils-r1_src_install
-
- rm -vf "${ED}"usr/share/parti/{parti.,}README \
- "${ED}"usr/share/xpra/{webm/LICENSE,xpra.README} \
- "${ED}"usr/share/wimpiggy/wimpiggy.README || die
- dodoc {parti.,wimpiggy.,xpra.,}README
-}
diff --git a/x11-wm/xpra/xpra-0.9.5-r2.ebuild b/x11-wm/xpra/xpra-0.9.5-r2.ebuild
deleted file mode 100644
index 2f61645d5b64..000000000000
--- a/x11-wm/xpra/xpra-0.9.5-r2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/xpra-0.9.5-r2.ebuild,v 1.2 2013/08/11 23:02:34 aballier Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-inherit distutils-r1 eutils
-
-DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
-HOMEPAGE="http://xpra.org/"
-SRC_URI="http://xpra.org/src/${P}.tar.bz2"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+clipboard opengl pulseaudio +rencode server sound vpx webp x264"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# x264/old-libav.path situation see bug 459218
-COMMON_DEPEND=""${PYTHON_DEPS}"
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXtst
- opengl? ( dev-python/pygtkglext )
- pulseaudio? ( media-sound/pulseaudio )
- sound? ( media-libs/gstreamer
- media-libs/gst-plugins-base
- dev-python/gst-python )
- vpx? ( media-libs/libvpx
- virtual/ffmpeg )
- webp? ( media-libs/libwebp )
- x264? ( media-libs/x264
- || ( >=media-video/ffmpeg-1.0.4:0 media-video/libav )
- virtual/ffmpeg )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- virtual/python-imaging[${PYTHON_USEDEP}]
- virtual/ssh
- x11-apps/setxkbmap
- x11-apps/xmodmap
- server? ( x11-base/xorg-server[-minimal,xvfb]
- x11-drivers/xf86-input-void
- x11-drivers/xf86-video-dummy
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- epatch \
- "${FILESDIR}"/${PN}-0.7.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.8.0-prefix.patch \
- "${FILESDIR}"/${PN}-0.9.5-PIL.patch \
- "${FILESDIR}"/${PN}-0.9.5-opengl-auto.patch
-
- #assuming ffmpeg and libav mutual exclusive installs
- if has_version "media-video/libav" ; then
- if ! has_version ">=media-video/libav-9" ; then
- epatch patches/old-libav.patch
- fi
- fi
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(use_with clipboard)
- $(use_with opengl)
- $(use_with rencode)
- $(use_with server)
- $(use_with sound)
- $(use_with vpx)
- $(use_with webp)
- $(use_with x264)
- --with-cymaths
- --with-cyxor
- --with-parti
- --with-shadow
- --with-strict
- --with-warn
- --without-PIC
- --without-debug )
-}
-
-src_install() {
- distutils-r1_src_install
-
- rm -vf "${ED}"usr/share/parti/{parti.,}README \
- "${ED}"usr/share/xpra/{webm/LICENSE,xpra.README} \
- "${ED}"usr/share/wimpiggy/wimpiggy.README || die
- dodoc {parti.,wimpiggy.,xpra.,}README
-}
diff --git a/x11-wm/xpra/xpra-0.9.7.ebuild b/x11-wm/xpra/xpra-0.9.7.ebuild
deleted file mode 100644
index 5b4447bcc44c..000000000000
--- a/x11-wm/xpra/xpra-0.9.7.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xpra/xpra-0.9.7.ebuild,v 1.2 2013/08/11 23:02:34 aballier Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-inherit distutils-r1 eutils
-
-DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
-HOMEPAGE="http://xpra.org/"
-SRC_URI="http://xpra.org/src/${P}.tar.bz2"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+clipboard opengl pulseaudio +rencode server sound vpx webp x264"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# x264/old-libav.path situation see bug 459218
-COMMON_DEPEND=""${PYTHON_DEPS}"
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXtst
- opengl? ( dev-python/pygtkglext )
- pulseaudio? ( media-sound/pulseaudio )
- sound? ( media-libs/gstreamer
- media-libs/gst-plugins-base
- dev-python/gst-python )
- vpx? ( media-libs/libvpx
- virtual/ffmpeg )
- webp? ( media-libs/libwebp )
- x264? ( media-libs/x264
- || ( >=media-video/ffmpeg-1.0.4:0 media-video/libav )
- virtual/ffmpeg )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- virtual/python-imaging[${PYTHON_USEDEP}]
- virtual/ssh
- x11-apps/setxkbmap
- x11-apps/xmodmap
- server? ( x11-base/xorg-server[-minimal,xvfb]
- x11-drivers/xf86-input-void
- x11-drivers/xf86-video-dummy
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- epatch \
- "${FILESDIR}"/${PN}-0.7.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.8.0-prefix.patch \
- "${FILESDIR}"/${PN}-0.9.5-opengl-auto.patch
-
- #assuming ffmpeg and libav mutual exclusive installs
- if has_version "media-video/libav" ; then
- if ! has_version ">=media-video/libav-9" ; then
- epatch patches/old-libav.patch
- fi
- fi
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(use_with clipboard)
- $(use_with opengl)
- $(use_with rencode)
- $(use_with server)
- $(use_with sound)
- $(use_with vpx)
- $(use_with webp)
- $(use_with x264)
- --with-cymaths
- --with-cyxor
- --with-parti
- --with-shadow
- --with-strict
- --with-warn
- --without-PIC
- --without-debug )
-}
-
-src_install() {
- distutils-r1_src_install
-
- rm -vf "${ED}"usr/share/parti/{parti.,}README \
- "${ED}"usr/share/xpra/{webm/LICENSE,xpra.README} \
- "${ED}"usr/share/wimpiggy/wimpiggy.README || die
- dodoc {parti.,wimpiggy.,xpra.,}README
-}