summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2006-12-06 17:03:50 +0000
committerSteve Dibb <beandog@gentoo.org>2006-12-06 17:03:50 +0000
commit6fd0f19f5f15fad839cf831379b6c7e35f26fb89 (patch)
tree21bf32a90a07d3f8cd425d004d2896f04f459817 /x11-wm
parentRemoved sed-4 from *DEPEND. (diff)
downloadgentoo-2-6fd0f19f5f15fad839cf831379b6c7e35f26fb89.tar.gz
gentoo-2-6fd0f19f5f15fad839cf831379b6c7e35f26fb89.tar.bz2
gentoo-2-6fd0f19f5f15fad839cf831379b6c7e35f26fb89.zip
Version bump, add myself as another maintainer
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/icewm/ChangeLog8
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.2.293
-rw-r--r--x11-wm/icewm/icewm-1.2.29.ebuild102
-rw-r--r--x11-wm/icewm/metadata.xml4
4 files changed, 116 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index d7da7efa7767..6384fb031e29 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.112 2006/11/19 02:45:23 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.113 2006/12/06 17:03:50 beandog Exp $
+
+*icewm-1.2.29 (06 Dec 2006)
+
+ 06 Dec 2006; Steve Dibb <beandog@gentoo.org> metadata.xml,
+ +icewm-1.2.29.ebuild:
+ Version bump, add myself as another maintainer
19 Nov 2006; Saleem Abdulrasool <compnerd@gentoo.org> icewm-1.2.23.ebuild,
icewm-1.2.25.ebuild, icewm-1.2.26.ebuild:
diff --git a/x11-wm/icewm/files/digest-icewm-1.2.29 b/x11-wm/icewm/files/digest-icewm-1.2.29
new file mode 100644
index 000000000000..46d98c039278
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.2.29
@@ -0,0 +1,3 @@
+MD5 0342359398643c36eff313f680678e28 icewm-1.2.29.tar.gz 1055906
+RMD160 ac77e10d365852998bfef0c5d2a9181acfc7ec64 icewm-1.2.29.tar.gz 1055906
+SHA256 2be1b9c96c621cf3cdd56ec84d536ba2a04768098f08547a5ab7195a18a85dc3 icewm-1.2.29.tar.gz 1055906
diff --git a/x11-wm/icewm/icewm-1.2.29.ebuild b/x11-wm/icewm/icewm-1.2.29.ebuild
new file mode 100644
index 000000000000..d1e694242f4a
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.2.29.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.2.29.ebuild,v 1.1 2006/12/06 17:03:50 beandog Exp $
+
+inherit eutils
+
+DESCRIPTION="Ice Window Manager with Themes"
+
+HOMEPAGE="http://www.icewm.org/
+ http://sourceforge.net/projects/icewmsilverxp/"
+
+#fix for icewm preversion package names
+S=${WORKDIR}/${P/_}
+
+SRC_URI="mirror://sourceforge/${PN}/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="esd imlib nls spell truetype xinerama silverxp"
+
+RDEPEND="|| ( (
+ x11-libs/libXau
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libXt
+ x11-libs/libXdmcp )
+ virtual/x11 )
+ esd? ( media-sound/esound )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )
+ nls? ( sys-devel/gettext )
+ truetype? ( >=media-libs/freetype-2.0.9 )
+ media-fonts/artwiz-fonts
+ media-libs/giflib"
+
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto )
+ virtual/x11 )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src
+ if use silverxp ; then
+ epatch ${FILESDIR}/${P/_}.ybutton.cc.patch
+ fi
+
+ echo "#!/bin/sh" > $T/icewm
+ echo "/usr/bin/icewm-session" >> $T/icewm
+
+}
+
+src_compile(){
+
+ if use truetype
+ then
+ myconf="${myconf} --enable-gradients --enable-shape --enable-movesize-fx --enable-shaped-decorations"
+ else
+ myconf="${myconf} --disable-xfreetype --enable-corefonts"
+ fi
+
+ CXXFLAGS="${CXXFLAGS}" econf \
+ --with-libdir=/usr/share/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ $(use_with esd esd-config /usr/bin/esd-config) \
+ $(use_enable nls) \
+ $(use_enable nls i18n) \
+ $(use_with imlib) \
+ $(use_enable spell GtkSpell) \
+ $(use_enable x86 x86-asm) \
+ $(use_enable xinerama) \
+ ${myconf} || die "configure failed"
+
+ sed -i "s:/icewm-\$(VERSION)::" src/Makefile || die "patch failed"
+ sed -i "s:ungif:gif:" src/Makefile || die "libungif fix failed"
+
+ emake || die "emake failed"
+}
+
+src_install(){
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS BUGS CHANGES FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ exeinto /etc/X11/Sessions
+ doexe $T/icewm
+
+ insinto /usr/share/xsessions
+ doins ${FILESDIR}/IceWM.desktop
+}
diff --git a/x11-wm/icewm/metadata.xml b/x11-wm/icewm/metadata.xml
index 00fe1ff1402b..34b4579a337c 100644
--- a/x11-wm/icewm/metadata.xml
+++ b/x11-wm/icewm/metadata.xml
@@ -6,6 +6,10 @@
<email>bcowan@gentoo.org</email>
<name>Brad Cowan</name>
</maintainer>
+<maintainer>
+ <email>beandog@gentoo.org</email>
+ <name>Steve Dibb</name>
+</maintainer>
<longdescription>
IceWM is a window manager designed for speed, usability, and consistency.
It is able to emulate the looks of Motif, OS/2, and Windows, and allows you