summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-03-01 11:28:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-03-01 11:28:22 +0000
commite17e85ac2ef88cbd0706893f99119e1d5b5da01b (patch)
treed84bcee1b00bcaa342d7459909db330ecb41313f /x11-wm
parentVersion bump to be in sync with the rest; no code changes. Remove old. (diff)
downloadgentoo-2-e17e85ac2ef88cbd0706893f99119e1d5b5da01b.tar.gz
gentoo-2-e17e85ac2ef88cbd0706893f99119e1d5b5da01b.tar.bz2
gentoo-2-e17e85ac2ef88cbd0706893f99119e1d5b5da01b.zip
Fixed LDFLAGS leak to pkgconfig file.
(Portage version: 2.2.8_p53/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/blackbox/ChangeLog10
-rw-r--r--x11-wm/blackbox/blackbox-0.70.1-r1.ebuild58
-rw-r--r--x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch14
3 files changed, 80 insertions, 2 deletions
diff --git a/x11-wm/blackbox/ChangeLog b/x11-wm/blackbox/ChangeLog
index 3948c3979fbc..4e20254ae250 100644
--- a/x11-wm/blackbox/ChangeLog
+++ b/x11-wm/blackbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/blackbox
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.71 2013/10/19 15:20:22 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.72 2014/03/01 11:28:22 slyfox Exp $
+
+*blackbox-0.70.1-r1 (01 Mar 2014)
+
+ 01 Mar 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +blackbox-0.70.1-r1.ebuild, +files/blackbox-0.70.1-no-LDFLAGS-pc.patch:
+ Fixed LDFLAGS leak to pkgconfig file.
19 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due desktop-wm removal
diff --git a/x11-wm/blackbox/blackbox-0.70.1-r1.ebuild b/x11-wm/blackbox/blackbox-0.70.1-r1.ebuild
new file mode 100644
index 000000000000..57f65f9679b7
--- /dev/null
+++ b/x11-wm/blackbox/blackbox-0.70.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.70.1-r1.ebuild,v 1.1 2014/03/01 11:28:21 slyfox Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A small, fast, full-featured window manager for X"
+HOMEPAGE="http://blackboxwm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}wm/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls truetype debug"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXt
+ nls? ( sys-devel/gettext )
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-apps/sed-4
+ x11-proto/xextproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-no-LDFLAGS-pc.patch
+
+ sed -i -e "s/_XUTIL_H_/_X11&/" lib/Util.hh || die #348556
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/X11/${PN} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable truetype xft)
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/blackbox" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
+
+ prune_libtool_files --all
+}
diff --git a/x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch b/x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch
new file mode 100644
index 000000000000..e907b588b158
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch
@@ -0,0 +1,14 @@
+Fix LDFGAS leak to .pc file:
+> * QA Notice: pkg-config files with wrong LDFLAGS detected:
+> * /usr/lib64/pkgconfig/libbt.pc:Libs: -L${libdir} -lbt -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -L/usr/lib -L/usr/local/lib
+diff --git a/lib/libbt.pc.in b/lib/libbt.pc.in
+index a2a8869..8246cb0 100644
+--- a/lib/libbt.pc.in
++++ b/lib/libbt.pc.in
+@@ -7,5 +7,5 @@ Name: Blackbox Toolbox
+ Description: Utility class library for writing small applications
+ Requires: @XFT_PKGCONFIG@
+ Version: @VERSION@
+-Libs: -L${libdir} -lbt @LDFLAGS@ @ICONV@ @LOCALE@
++Libs: -L${libdir} -lbt @ICONV@ @LOCALE@
+ Cflags: -I${includedir}/bt