summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-08 12:03:13 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-08 12:03:13 +0000
commitfec434edf18a44c1538d1bfb08a23cf5eed7729a (patch)
treedc5e34f257f3a30a28a2fe6e8b718862cd37ba9f /x11-wm
parentFix deadlock, bug #420353 by Michael Boone. (diff)
downloadgentoo-2-fec434edf18a44c1538d1bfb08a23cf5eed7729a.tar.gz
gentoo-2-fec434edf18a44c1538d1bfb08a23cf5eed7729a.tar.bz2
gentoo-2-fec434edf18a44c1538d1bfb08a23cf5eed7729a.zip
Version bump.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog7
-rw-r--r--x11-wm/sawfish/sawfish-1.9.0.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 896fc32234d8..cb8caebb6371 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/sawfish
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.110 2012/05/04 08:58:58 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.111 2012/07/08 12:03:13 pacho Exp $
+
+*sawfish-1.9.0 (08 Jul 2012)
+
+ 08 Jul 2012; Pacho Ramos <pacho@gentoo.org> +sawfish-1.9.0.ebuild:
+ Version bump.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> sawfish-1.8.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-wm/sawfish/sawfish-1.9.0.ebuild b/x11-wm/sawfish/sawfish-1.9.0.ebuild
new file mode 100644
index 000000000000..16457338c9dd
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.9.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-1.9.0.ebuild,v 1.1 2012/07/08 12:03:13 pacho Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawfish.wikia.com/"
+if (( snapshot )); then
+ SRC_URI="mirror://gentoo/${P/_p/.}.tar.bz2"
+else
+ SRC_URI="http://download.tuxfamily.org/sawfish/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND=">=dev-libs/librep-0.92.1
+ >=x11-libs/rep-gtk-0.90.7
+ >=x11-libs/pango-1.8.0[X]
+ >=x11-libs/gtk+-2.24.0:2
+ x11-libs/libXtst
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ set -- \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf \
+ --disable-static
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas="" as
+ # "install everything"
+ # Don't use --disable-linguas, because that means --enable-linguas="no",
+ # which means "install Norwegian translations"
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog DOC FAQ NEWS OPTIONS README README.IMPORTANT TODO
+}