summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-05-02 12:34:51 +0000
committerSamuli Suominen <drac@gentoo.org>2007-05-02 12:34:51 +0000
commit713bcddb5d95b6c8e30133f8c9b4fb0c12accb2d (patch)
tree9c9136635f965aff9e3f34f2c245ad4540215019 /xfce-base/thunar
parentMarked stable on x86, to work with stable ffmpeg. (diff)
downloadgentoo-2-713bcddb5d95b6c8e30133f8c9b4fb0c12accb2d.tar.gz
gentoo-2-713bcddb5d95b6c8e30133f8c9b4fb0c12accb2d.tar.bz2
gentoo-2-713bcddb5d95b6c8e30133f8c9b4fb0c12accb2d.zip
Apply patch from upstream to fix bug 173795, adding quotes to UCA browse. Thanks to Alexander Skwar for reporting.
(Portage version: 2.1.2.5)
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/ChangeLog9
-rw-r--r--xfce-base/thunar/files/digest-thunar-0.8.0-r33
-rw-r--r--xfce-base/thunar/files/thunar-0.8.0-uca.patch19
-rw-r--r--xfce-base/thunar/thunar-0.8.0-r3.ebuild78
4 files changed, 108 insertions, 1 deletions
diff --git a/xfce-base/thunar/ChangeLog b/xfce-base/thunar/ChangeLog
index 46cb35f14b5a..a1af25409025 100644
--- a/xfce-base/thunar/ChangeLog
+++ b/xfce-base/thunar/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/thunar
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.28 2007/03/15 13:29:34 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/ChangeLog,v 1.29 2007/05/02 12:34:51 drac Exp $
+
+*thunar-0.8.0-r3 (02 May 2007)
+
+ 02 May 2007; Samuli Suominen <drac@gentoo.org>
+ +files/thunar-0.8.0-uca.patch, +thunar-0.8.0-r3.ebuild:
+ Apply patch from upstream to fix bug 173795, adding quotes to UCA browse.
+ Thanks to Alexander Skwar for reporting.
15 Mar 2007; Markus Rothe <corsair@gentoo.org> thunar-0.8.0-r2.ebuild:
Stable on ppc64; bug #169987
diff --git a/xfce-base/thunar/files/digest-thunar-0.8.0-r3 b/xfce-base/thunar/files/digest-thunar-0.8.0-r3
new file mode 100644
index 000000000000..36154971d4f9
--- /dev/null
+++ b/xfce-base/thunar/files/digest-thunar-0.8.0-r3
@@ -0,0 +1,3 @@
+MD5 9f7b0945d6a235391049f6818fb4d188 Thunar-0.8.0.tar.bz2 6205993
+RMD160 95d29cca64c102b7d8bdcc0592f6fcab7198148b Thunar-0.8.0.tar.bz2 6205993
+SHA256 460484f8397a0e0e4115d1629d2ae027b5052dc2c564d4a4629a3557e4a055f9 Thunar-0.8.0.tar.bz2 6205993
diff --git a/xfce-base/thunar/files/thunar-0.8.0-uca.patch b/xfce-base/thunar/files/thunar-0.8.0-uca.patch
new file mode 100644
index 000000000000..53d3dbc18852
--- /dev/null
+++ b/xfce-base/thunar/files/thunar-0.8.0-uca.patch
@@ -0,0 +1,19 @@
+Index: plugins/thunar-uca/thunar-uca-editor.c
+===================================================================
+--- plugins/thunar-uca/thunar-uca-editor.c (revision 25631)
++++ plugins/thunar-uca/thunar-uca-editor.c (working copy)
+@@ -582,7 +582,13 @@
+ if (gtk_dialog_run (GTK_DIALOG (chooser)) == GTK_RESPONSE_ACCEPT)
+ {
+ filename = gtk_file_chooser_get_filename (GTK_FILE_CHOOSER (chooser));
+- s = g_strconcat (filename, " %f", NULL);
++
++ /* quote the command when the filename contains spaces */
++ if (G_LIKELY (strchr (filename, ' ') == NULL))
++ s = g_strconcat (filename, " %f", NULL);
++ else
++ s = g_strconcat ("'", filename, "' %f", NULL);
++
+ gtk_entry_set_text (GTK_ENTRY (uca_editor->command_entry), s);
+ g_free (filename);
+ g_free (s);
diff --git a/xfce-base/thunar/thunar-0.8.0-r3.ebuild b/xfce-base/thunar/thunar-0.8.0-r3.ebuild
new file mode 100644
index 000000000000..d677fa54de1c
--- /dev/null
+++ b/xfce-base/thunar/thunar-0.8.0-r3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/thunar/thunar-0.8.0-r3.ebuild,v 1.1 2007/05/02 12:34:51 drac Exp $
+
+inherit eutils virtualx xfce44
+
+MY_P="${P/t/T}"
+S="${WORKDIR}/${MY_P}"
+
+xfce44
+
+DESCRIPTION="File manager"
+HOMEPAGE="http://thunar.xfce.org"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc dbus debug exif gnome hal plugins pcre startup-notification"
+
+RDEPEND=">=dev-lang/perl-5.6
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2.6
+ >=xfce-extra/exo-0.3.2
+ >=x11-misc/shared-mime-info-0.15
+ >=dev-util/desktop-file-utils-0.10
+ >=xfce-base/libxfce4util-${XFCE_MASTER_VERSION}
+ virtual/fam
+ dbus? ( || ( dev-libs/dbus-glib <sys-apps/dbus-1 ) )
+ hal? ( sys-apps/hal )
+ >=media-libs/freetype-2
+ gnome? ( gnome-base/gconf )
+ exif? ( >=media-libs/libexif-0.6 )
+ >=media-libs/jpeg-6b
+ startup-notification? ( x11-libs/startup-notification )
+ pcre? ( >=dev-libs/libpcre-6 )
+ plugins? ( dbus? ( >=xfce-base/xfce4-panel-${XFCE_MASTER_VERSION} ) )
+ gnome-base/librsvg"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ doc? ( dev-util/gtk-doc )"
+
+XFCE_CONFIG="${XFCE_CONFIG} $(use_enable exif) $(use_enable gnome gnome-thumbnailers) \
+ $(use_enable dbus) $(use_enable pcre)"
+
+pkg_setup() {
+ if use hal; then
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=hal"
+ else
+ XFCE_CONFIG="${XFCE_CONFIG} --with-volume-manager=none"
+ fi
+
+ if use plugins && ! use dbus ; then
+ XFCE_CONFIG="${XFCE_CONFIG} --disable-tpa-plugin"
+ ewarn "Plugins requires ${PN} with dbus support. Enable dbus use flag"
+ ewarn "and re-emerge this ebuild if you want this feature."
+ epause 3
+ fi
+
+ if use hal && ! use dbus ; then
+ ewarn "HAL requires ${PN} with dbus support. Enable dbus use flag"
+ ewarn "and re-emerge this ebuild if you want this feature."
+ die "re-emerge with USE dbus"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-jpeg.patch
+ epatch "${FILESDIR}"/${P}-uca.patch
+}
+
+src_test() {
+ Xemake check || "emake check failed."
+}
+
+DOCS="AUTHORS ChangeLog HACKING FAQ THANKS TODO README NEWS"
+
+xfce44_extra_package