summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2003-11-13 00:28:16 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2003-11-13 00:28:16 +0000
commit13450f5df9d417a53af78b3684833687836691c7 (patch)
tree12c6870f07b4f7b3f43d28bb994095718a503b79 /xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.0.1.ebuild
parentbugfix release of xfce4. (diff)
downloadgentoo-2-13450f5df9d417a53af78b3684833687836691c7.tar.gz
gentoo-2-13450f5df9d417a53af78b3684833687836691c7.tar.bz2
gentoo-2-13450f5df9d417a53af78b3684833687836691c7.zip
bugfix release of xfce4.
Diffstat (limited to 'xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.0.1.ebuild')
-rw-r--r--xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.0.1.ebuild b/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.0.1.ebuild
new file mode 100644
index 000000000000..a58965834161
--- /dev/null
+++ b/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.0.1.ebuild,v 1.1 2003/11/13 00:23:23 bcowan Exp $
+
+IUSE="X"
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Libraries for XFCE4"
+HOMEPAGE="http://www.xfce.org/"
+SRC_URI="http://www.xfce.org/archive/xfce-${PV}/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ia64 ~x86 ~ppc ~alpha ~sparc ~amd64"
+
+DEPEND=">=x11-libs/gtk+-2.0.6
+ dev-util/pkgconfig
+ dev-libs/libxml2
+ =xfce-base/libxfce4util-${PV}
+ =xfce-base/libxfcegui4-${PV}
+ =xfce-base/libxfce4mcs-${PV}
+ =xfce-base/xfce-mcs-manager-${PV}"
+
+src_compile() {
+ local myconf
+ myconf=""
+
+ use X \
+ && myconf="${myconf} --with-x --enable-xf86misc --enable-xkb"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS INSTALL COPYING README ChangeLog
+}