summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-03-10 13:49:56 +0000
committerChristoph Mende <angelos@gentoo.org>2009-03-10 13:49:56 +0000
commit23314ce6773cb42566bbf1bb94c76bf6fe026f14 (patch)
tree73df1bc178e43fdb346188d1d53a73cabba304b5 /xfce-base/xfce-utils
parentXfce-4.6 bump (diff)
downloadgentoo-2-23314ce6773cb42566bbf1bb94c76bf6fe026f14.tar.gz
gentoo-2-23314ce6773cb42566bbf1bb94c76bf6fe026f14.tar.bz2
gentoo-2-23314ce6773cb42566bbf1bb94c76bf6fe026f14.zip
Xfce-4.6 bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/ChangeLog10
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.6.0.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 5dc84a2655f3..99990da79066 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce-utils
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.131 2008/12/22 17:05:56 angelos Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.132 2009/03/10 13:49:56 angelos Exp $
+
+*xfce-utils-4.6.0 (10 Mar 2009)
+
+ 10 Mar 2009; Christoph Mende <angelos@gentoo.org>
+ +xfce-utils-4.6.0.ebuild:
+ Xfce-4.6 bump
22 Dec 2008; Christoph Mende <angelos@gentoo.org>
-xfce-utils-4.4.2-r1.ebuild:
diff --git a/xfce-base/xfce-utils/xfce-utils-4.6.0.ebuild b/xfce-base/xfce-utils/xfce-utils-4.6.0.ebuild
new file mode 100644
index 000000000000..387dd1ab271d
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.6.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.6.0.ebuild,v 1.1 2009/03/10 13:49:56 angelos Exp $
+
+EAPI=1
+
+inherit xfce4
+
+xfce4_core
+
+DESCRIPTION="Collection of utils"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus debug +lock"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libX11
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-${XFCE_VERSION}
+ >=xfce-base/libxfcegui4-${XFCE_VERSION}
+ >=xfce-base/xfconf-${XFCE_VERSION}
+ dbus? ( dev-libs/dbus-glib )
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+pkg_setup() {
+ XFCE_CONFIG+=" $(use_enable dbus) --with-vendor-info=Gentoo"
+}
+
+src_install() {
+ xfce4_src_install
+
+ insinto /usr/share/xfce4
+ doins "${FILESDIR}/Gentoo"
+
+ dodir /etc/X11/Sessions
+ echo startxfce4 > "${D}/etc/X11/Sessions/Xfce4"
+ fperms 755 /etc/X11/Sessions/Xfce4
+}
+
+pkg_postinst() {
+ elog
+ elog "Run Xfce4 from your favourite Display Manager by using"
+ elog "XSESSION=\"Xfce4\" in /etc/rc.conf"
+ elog
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"