summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-23 15:37:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-23 15:37:19 +0000
commitd07e78bd524e8fe6926e3f077d0e4a7525cfe3da (patch)
tree65866fd407a4d20e650892ab4c404083ea8d939d /xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
parentold (diff)
downloadgentoo-2-d07e78bd524e8fe6926e3f077d0e4a7525cfe3da.tar.gz
gentoo-2-d07e78bd524e8fe6926e3f077d0e4a7525cfe3da.tar.bz2
gentoo-2-d07e78bd524e8fe6926e3f077d0e4a7525cfe3da.zip
Convert stable ebuild also to xfconf.eclass.
(Portage version: 2.2_rc39/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild')
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild40
1 files changed, 23 insertions, 17 deletions
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
index f1a5c599c52e..6c57eba69964 100644
--- a/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild,v 1.11 2009/07/27 17:48:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.1.ebuild,v 1.12 2009/08/23 15:37:19 ssuominen Exp $
-EAPI="1"
+EAPI=2
+inherit xfconf
-inherit xfce4
+DESCRIPTION="Settings daemon for Xfce4"
+HOMEPAGE="http://www.xfce.org"
-xfce4_core
-
-DESCRIPTION="Xfce4 settings"
+LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="debug +keyboard libnotify sound"
@@ -22,23 +23,28 @@ RDEPEND=">=dev-libs/glib-2.12:2
x11-libs/libXrandr
x11-libs/libwnck
>=x11-base/xorg-server-1.5.3
- >=xfce-base/libxfce4util-${XFCE_VERSION}
- >=xfce-base/libxfcegui4-${XFCE_VERSION}
- >=xfce-base/xfconf-${XFCE_VERSION}
- !xfce-base/xfce-mcs-manager
- !xfce-base/xfce-mcs-plugins
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
>=xfce-extra/exo-0.3.100
libnotify? ( x11-libs/libnotify )
- keyboard? ( x11-libs/libxklavier )
+ keyboard? ( <x11-libs/libxklavier-4 )
sound? ( media-libs/libcanberra )"
DEPEND="${RDEPEND}
dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
x11-proto/inputproto
- x11-proto/xf86vidmodeproto"
+ x11-proto/xf86vidmodeproto
+ !xfce-base/xfce-mcs-manager
+ !xfce-base/xfce-mcs-plugins"
pkg_setup() {
- XFCE_CONFIG+=" $(use_enable libnotify) $(use_enable keyboard libxklavier)
- $(use_enable sound sound-settings) --enable-xcursor"
+ XFCONF="--disable-dependency-tracking
+ $(use_enable libnotify)
+ --enable-xcursor
+ $(use_enable keyboard libxklavier)
+ $(use_enable sound sound-settings)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog NEWS TODO"
}
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"